Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451541 - Review-Request: perl-Authen-Captcha - Perl extension for creating captcha's to verify the human element in transactions
Summary: Review-Request: perl-Authen-Captcha - Perl extension for creating captcha's t...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Extras Quality Assurance
URL: http://v3.sk/~lkundrak/SPECS/perl-Aut...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 12:57 UTC by Lubomir Rintel
Modified: 2014-03-06 13:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 19:04:09 UTC
panemade: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Lubomir Rintel 2008-06-15 12:57:13 UTC
SPEC: http://v3.sk/~lkundrak/SPECS/perl-Authen-Captcha.spec
SRPM:http://v3.sk/~lkundrak/SRPMS/perl-Authen-Captcha-1.023-2.el5.src.rpm

Description:

Authen::Captcha provides an object oriented interface to captcha file
creations. Captcha stands for Completely Automated Public Turning test to
tell Computers and Humans Apart.

Comment 1 Parag AN(पराग) 2008-06-18 09:59:37 UTC
rpmlint gave me
perl-Authen-Captcha.noarch: W: wrong-file-end-of-line-encoding
/usr/share/doc/perl-Authen-Captcha-1.023/license.txt
This file has wrong end-of-line encoding, usually caused by creation or
modification on a non-Unix system. It could prevent it from being displayed
correctly in some circumstances.

perl-Authen-Captcha.noarch: E: summary-too-long Perl extension for creating
captcha's to verify the human element in transactions
The "Summary:" must not exceed 79 characters.

perl-Authen-Captcha.noarch: W: incoherent-version-in-changelog 1.023-1 1.023-2.fc10
The last entry in %changelog contains a version identifier that is not
coherent with the epoch:version-release tuple of the package.


Comment 2 Lubomir Rintel 2008-06-23 08:06:41 UTC
Parag: Thanks for the review. I updated the packages and rpmlint seems to be
quiet now.

SPEC: http://v3.sk/~lkundrak/SPECS/perl-Authen-Captcha.spec
SRPM:http://v3.sk/~lkundrak/SRPMS/perl-Authen-Captcha-1.023-2.el5.src.rpm

(Sorry that I use the same filenames, but it is due to the fact that the former
one had incorrect revision number, as you found out.)

[lkundrak@trurl SPECS]$ rpmlint -i
/home/lkundrak/rpmbuild/SRPMS/perl-Authen-Captcha-1.023-2.el5.src.rpm
/home/lkundrak/rpmbuild/RPMS/noarch/perl-Authen-Captcha-1.023-2.el5.noarch.rpm
[lkundrak@trurl SPECS]$ 



Comment 3 Lubomir Rintel 2008-06-23 08:10:21 UTC
SPEC: http://netbsd.sk/~lkundrak/SPECS/perl-Authen-Captcha.spec
SRPM: http://netbsd.sk/~lkundrak/SRPMS/perl-Authen-Captcha-1.023-2.el5.src.rpm

For that seems that mod_rewrites don't work as they used to :)

Comment 4 Parag AN(पराग) 2008-06-23 08:54:36 UTC
Review:
+ package builds in mock.
Koji build => http://koji.fedoraproject.org/koji/taskinfo?taskID=676063
+ rpmlint is silent for SRPM and for RPM.
+ source files match upstream url
7c20090844dd2406e4ef6a894c66348b  Authen-Captcha-1.023.tar.gz
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is present.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no scriptlets present.
+ no duplicates in %files.
+ file permissions are appropriate.
+ make test
All tests successful.
Files=1, Tests=32,  0 wallclock secs ( 0.13 cusr +  0.01 csys =  0.14 CPU)
+Package perl-Authen-Captcha-1.023-2.fc10 =>
Provides: perl(Authen::Captcha) = 1.23
Requires: perl >= 0:5.00503 perl(:MODULE_COMPAT_5.10.0)
 perl(Carp) perl(Digest::MD5) perl(File::Basename) perl(File::Spec) perl(GD)
perl(strict) perl(vars)

APPROVED.

Comment 5 Lubomir Rintel 2008-06-23 10:21:58 UTC
Danke schon, Parag.

New Package CVS Request
=======================
Package Name: perl-Authen-Captcha
Short Description: Perl extension for creating captcha's to verify the human
element in transactions
Owners: lkundrak
Branches: F-8 F-9 EL-5
Cvsextras Commits: yes

Comment 6 Kevin Fenzi 2008-06-23 15:31:26 UTC
cvs done.

Comment 7 Lubomir Rintel 2008-06-23 19:04:09 UTC
Thanks Parag, thanks Kevin.
Imported and built.

Comment 8 Lubomir Rintel 2014-03-04 10:19:59 UTC
Package Change Request
======================
Package Name: perl-Authen-Captcha
New Branches: epel7
Owners: lkundrak eseyman

A message from eseyman, the current Fedora maintainer of the package: "I don't use EPEL so I'm probably not the best choice for a maintainer. Feel free to ask for a branch for any of my modules. If you do, please consider adding me as co-maintainer."

Comment 9 Gwyn Ciesla 2014-03-06 13:17:10 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.