Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451520 - 32bit applications do not run on x86_64 xen guest
Summary: 32bit applications do not run on x86_64 xen guest
Keywords:
Status: CLOSED DUPLICATE of bug 437358
Alias: None
Product: Fedora
Classification: Fedora
Component: xen
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 10:42 UTC by Bjørn Tore Sund
Modified: 2008-06-15 16:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-15 16:39:02 UTC


Attachments (Terms of Use)

Description Bjørn Tore Sund 2008-06-15 10:42:53 UTC
Description of problem:
Any attempt to execute a 32bit compiled application on an x86_64 Fedora 9 xen
guest fails, both Fedora-supplied applications and 3rd party applications. 
Crashes with "cannot execute binary file", strace dumps "write(3, "strace: exec:
Exec format error\n", 32strace: exec: Exec format error) = 32" very quickly.


Version-Release number of selected component (if applicable):
Running Fedora 9 guest on RHEL 5.2 host, both x86_64 and fully patched, Fedora 9
guest with kernel 2.6.25.3-1.fc9.x86_64.xen.

How reproducible:
100% reproducible.  Happens every time.  Problem not visible on identical x86_64
bit installation on desktop machine, problem also not visible on Fedora 8 or 7
x86_64 guest installations.

Steps to Reproduce:
1. On 64bit host, try executing for instance /usr/bin/mbchk from
grub-0.97-33.fc9.x86_64 - but any 32bit application will do.
  
Actual results:
It crashes.

Expected results:
It doesn't crash. :)

Additional info:
The only difference between the xen guest and a normal installation should be
the kernel, so I suspect there's a parameter in there not set?

Comment 1 Eduardo Habkost 2008-06-15 16:39:02 UTC
IA 32 emulation wasn't supported on kernel-xen 2.6.25.3-1.fc9.x86_64.xen. It was
added on kernel-xen-2.6-2.6.25.3-2.fc9.

*** This bug has been marked as a duplicate of 437358 ***


Note You need to log in before you can comment on or make changes to this bug.