Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451510 - After recent update Intel wireless 4965 stops connecting and hangs computer
Summary: After recent update Intel wireless 4965 stops connecting and hangs computer
Keywords:
Status: CLOSED DUPLICATE of bug 451395
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 04:48 UTC by Cameron Cross
Modified: 2008-06-23 19:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-23 19:01:24 UTC


Attachments (Terms of Use)

Description Cameron Cross 2008-06-15 04:48:38 UTC
Description of problem:

When i try to connect to the wireless at my home the computer hangs and the caps
lock and scroll lock lights keep flashing. I then have to force the computer to
shutdown.

Version-Release number of selected component (if applicable):

Not sure but it is the lastest update. After that it stopped working

How reproducible:

Always happens to me every time.

Steps to Reproduce:
1.Turn on computer with intel wireless 4965 agn adapeter
2.Try to connect to wireless point
3.Hang. Keyboard and mouse lock up and caps and scroll lock lights flash.
  
Actual results:

Hang. Keyboard and mouse lock up and caps and scroll lock lights flash.

Expected results:

Connects to wireless access point with out any fuss.

Additional info:

I can get my netgear wireless adapter to connect  no problems. Both nm-applet
and system-config-network hang. System-config-network says "obtaining ip
address". If you need more info email me -> "cameroncros@gmail.com"

Comment 1 Cameron Cross 2008-06-15 08:14:08 UTC
it might actually be kernel related because if i boot the old kernel it works
fine. Not sure why.

Comment 2 Alexander Stevenson 2008-06-16 08:32:04 UTC
I have the same problem with Intel 4965 AG (or AGN) with the new kernel. I have
to boot with the older kernel to avoid crashing.

Comment 3 Nicolas Chauvet (kwizart) 2008-06-17 16:10:26 UTC
This bug has been assigned to the wrong component.
You seesm to say that a recent kernel update have made the kernel crash without
telling which kernel (uname -r) it was...

Please report this info along with others valuable info such as vendor/models of
the laptop.

Comment 4 Tauroka 2008-06-19 10:43:05 UTC
I'm having this problem too but with the x86_64 kernel.
Kernel.x86_64-2.6.25-14.fc9 is happy either with during boot or after boot
network activiation.
Kernel.x86_64-2.6.25.6-55.fc9 hangs the machine with a flashing caps lock light
on boot if activate on boot is selected.
If activate on boot is not selected, activation of the network through
System->Admin->Network will not connect to the network.  Selection of Controlled
by NetworkManager results in NetworkManager attempting to connect resulting in a
hang.
Booting back to the earlier kernel results in a functioning machine with network
connection.


Comment 5 Alexander Stevenson 2008-06-19 15:56:56 UTC
My influenced kernel is 2.6.25.6-55.fc9.i686

This is my network controller:
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN
Network Connection (rev 61)

Laptop vendor/model is Ninjutsu Siemens/Amilo

Comment 6 Tauroka 2008-06-20 07:28:40 UTC
(In reply to comment #5)
> My influenced kernel is 2.6.25.6-55.fc9.i686
> 
> This is my network controller:
> 04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN
> Network Connection (rev 61)
> 
> Laptop vendor/model is Ninjutsu Siemens/Amilo

What processor are you using Alex?

Comment 7 Alexander Stevenson 2008-06-20 08:39:56 UTC
$ cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     T8100  @ 2.10GHz
stepping	: 6
cpu MHz		: 800.000
cache size	: 3072 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon
pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm ida
bogomips	: 4193.04
clflush size	: 64

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     T8100  @ 2.10GHz
stepping	: 6
cpu MHz		: 800.000
cache size	: 3072 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon
pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr sse4_1 lahf_lm ida
bogomips	: 4189.41
clflush size	: 64



Comment 8 Ian 2008-06-22 19:16:52 UTC
I am having the same problem on 2.6.25.6-55.fc9.x86_64 with an Intel 4965 AGN
wifi card. I can get my computer to boot by eater using an older kernel version
or by booting with wifi off, but if I turn it on it will freeze.

Comment 9 Ian 2008-06-22 21:18:00 UTC
This bug seems to be the same as https://bugzilla.redhat.com/show_bug.cgi?id=451723

Comment 10 John W. Linville 2008-06-23 19:01:24 UTC

*** This bug has been marked as a duplicate of 451395 ***


Note You need to log in before you can comment on or make changes to this bug.