Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451504 - telinit fails to switch runlevel
Summary: telinit fails to switch runlevel
Status: CLOSED DUPLICATE of bug 450488
Alias: None
Product: Fedora
Classification: Fedora
Component: upstart
Version: 9
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Casey Dahlin
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2008-06-15 02:07 UTC by Trevin Beattie
Modified: 2014-06-18 08:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-08-04 20:37:18 UTC

Attachments (Terms of Use)

Description Trevin Beattie 2008-06-15 02:07:03 UTC
Description of problem:
I've recently installed Fedora 9.  In order to compile the nVidia video driver
for my system, I need to exit out of X.  Normally I'd do this by running
"telinit 3", which would kill the running X server and gdm.  When I run this on
FC9, nothing happens.

Version-Release number of selected component (if applicable):

How reproducible:
Every time so far.

Steps to Reproduce:
1. Boot normally
2. Open a terminal
3. Run "telinit 3"
Actual results:
Nothing happens

Expected results:
X should shut down, leaving me at a text-based console.

Additional info:
I'll try editing the default runlevel in /etc/inittab next.

Comment 1 Casey Dahlin 2008-06-15 02:36:48 UTC
We've had a lot of these. Its almost always a duplicate of Bug #450488

Tell me what initctl list says just before this problem occurs to confirm.

Comment 2 Trevin Beattie 2008-06-15 17:11:28 UTC
Sorry, I wasn't able to reproduce the problem after a reboot.  I switched the
default runlevel to 3 and successfully used telinit to switch to 5 and back to
3.  Then I changed the default back to 5, rebooted, and used telinit to switch
to 3 and back to 5 and it worked.

Maybe it has something to do with the fact that the first time I tried it was
right after gnome-packagekit upgraded several dozen packages from the original
release to the current updates?

Comment 3 Casey Dahlin 2008-06-16 13:47:00 UTC
run telinit u and see if the problem comes back.

Comment 4 Trevin Beattie 2008-06-18 02:38:20 UTC
Yep.  Here's the initctl list now, if you're interested:

control-alt-delete (stop) waiting
logd (stop) waiting
prefdm (stop) waiting
rc0 (stop) waiting
rc1 (stop) waiting
rc2 (stop) waiting
rc3 (stop) waiting
rc4 (stop) waiting
rc5 (stop) waiting
rc6 (stop) waiting
rcS (stop) waiting
rcS-sulogin (stop) waiting
serial (instance)
sulogin (stop) waiting
tty1 (start) running, process 3257
tty2 (start) running, process 3255
tty3 (start) running, process 3256
tty4 (start) running, process 3253
tty5 (start) running, process 3254
tty6 (start) running, process 3258

The only difference I see is that prefdm is stopped, which is the same state it
would be in if I booted to runlevel 3, but an runlevel 5 it's normally running.

What does 'telinit u' do?  That's not listed on the man page.

Comment 5 Casey Dahlin 2008-08-04 20:37:18 UTC
telinit u is reexec. We get this issue frequently.

Marking as duplicate.

*** This bug has been marked as a duplicate of bug 450488 ***

Note You need to log in before you can comment on or make changes to this bug.