Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451497 - Version dependency problem in eclipse-mylyn
Summary: Version dependency problem in eclipse-mylyn
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-15 00:25 UTC by Michel Alexandre Salim
Modified: 2009-08-18 09:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-18 09:28:46 UTC


Attachments (Terms of Use)
Screenshot of failed installation process (deleted)
2008-06-15 00:25 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2008-06-15 00:25:34 UTC
Description of problem:
Attempting to install the beta version of the Scala plugin from scala-lang.org,
which depends on Mylyn, triggers the following error:

Mylyn Bridge: PDE, CVS and Ant (2.3.2.v20080402-2100) requires plug-in
"org.eclipse.mylyn.tasks.core (2.3.0)", or compatible


Version-Release number of selected component (if applicable):
2.3.2-6

How reproducible:
Always

Steps to Reproduce:
1. yum install eclipse-mylyn\*
2. install Scala plugin: http://www.scala-lang.org/downloads/scala-plugin-beta/
  
Actual results:
Error message described

Expected results:
Should work

Additional info:
The summaries for -ide, -java and -pde could perhaps be made more descriptive.

Comment 1 Michel Alexandre Salim 2008-06-15 00:25:34 UTC
Created attachment 309379 [details]
Screenshot of failed installation process

Comment 2 Andrew Overholt 2008-06-23 16:15:42 UTC
AFAICT all of the Mylyn plugins have this in META-INF/MANIFEST.MF:

org.eclipse.mylyn.tasks.core;bundle-version="[2.3.0,3.0.0)"

meaning they should accept 2.3.2.  Is there perhaps a deeper error here?  The
update manager in Eclipse <= 3.3.x doesn't properly expose plugins that are in
/usr/lib (these are arch-specific plugins called "fragments").  This upstream
bug has not been fixed and sometimes 3rd party plugins like this Scala plugin
depend upon something that is arch-specific.

Have you thought about packaging this for Fedora?  It's not hard and I wouldn't
mind helping you out.

Comment 3 Michel Alexandre Salim 2008-07-15 19:54:14 UTC
(Sorry for the late reply, was watching the status which is still NEW)

I've thought of packaging -- will Fedora 10 have Eclipse 3.4? In that case I
might just package the next version of the plugin, which requires that.

The Scala plugin bundles its own copy of Scala; is that the norm for
Eclipse-related packages or would I have to patch it to use a standalone
installation?

Comment 4 Andrew Overholt 2008-07-15 20:50:07 UTC
Yes, Fedora 10 will have Eclipse 3.4.

The Fedora guidelines specify that there should only be one copy of things on
the system so you'd have to patch it to use the system Scala.

Comment 5 John Poelstra 2008-10-19 02:26:11 UTC
Can this bug be considered resolved?

Comment 6 Andrew Overholt 2008-10-20 13:10:49 UTC
Michel?

Comment 7 Bug Zapper 2008-11-26 02:25:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Alexander Kurtakov 2009-08-18 09:28:46 UTC
No response from reporter for 8 months. Additionally it was reported against F-9.


Note You need to log in before you can comment on or make changes to this bug.