Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451490 - PyQt4 is built without QtWebKit support
Summary: PyQt4 is built without QtWebKit support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: PyQt4
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 20:02 UTC by Michal Schmidt
Modified: 2008-06-14 21:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-14 21:43:05 UTC


Attachments (Terms of Use)

Description Michal Schmidt 2008-06-14 20:02:01 UTC
Description of problem:

PyQt4 is built without QtWebKit support. The problem seems to be a missing
BuildRequires on sqlite-devel (or maybe qt-devel should Require it?).
From Koji build.log -
http://kojipkgs.fedoraproject.org/packages/PyQt4/4.4.2/1.fc10/data/logs/x86_64/build.log
:

Checking to see if the QtWebKit module should be built...
g++ -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_CORE_LIB -I.
-I/usr/lib64/qt4/mkspecs/default -I/usr/include/QtWebKit -I/usr/include/QtCore
-I/usr/include -I/usr/X11R6/include -pipe -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2  -fstack-protector --param=ssp-buffer-size=4 -m64
-mtune=generic -w -D_REENTRANT cfgtest_QtWebKit.cpp -o cfgtest_QtWebKit
-L/usr/X11R6/lib64 -lQtWebKit -L/usr/lib64 -lsqlite3 -lQtGui -L/usr/lib64
-L/usr/X11R6/lib64 -lQtNetwork -lQtCore -lQtCore -L/usr/lib64 -lXext -lX11 -lm
-lpthread
/usr/bin/ld: cannot find -lsqlite3
collect2: ld returned 1 exit status

Version-Release number of selected component (if applicable):
PyQt4-4.4.2-1.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
 python -c 'from PyQt4 import QtWebKit'
  
Actual results:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: cannot import name QtWebKit

Expected results:
QtWebKit should be imported successfully.

Additional info:
I have built the package locally with sqlite-devel installed and the resulting
PyQt4 RPM contains a working QtWebKit.

Comment 1 Rex Dieter 2008-06-14 21:12:28 UTC
It's qt at fault here:

$ pkg-config --libs QtWebKit
-lQtWebKit -lsqlite3 -lQtGui -lQtNetwork -lQtCore

I'll take care of qt, and then rebuilt PyQt4

Comment 2 Rex Dieter 2008-06-14 21:43:05 UTC
Fixed in rawhide:
qt-4.4.0-10
PyQt4-4.4.2-2

http://koji.fedoraproject.org/koji/taskinfo?taskID=662250


Note You need to log in before you can comment on or make changes to this bug.