Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451446 - pm_ack not dropped when component changed to a not already approved component
Summary: pm_ack not dropped when component changed to a not already approved component
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 3.2
Hardware: All
OS: Linux
medium
high vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 16:48 UTC by Doug Ledford
Modified: 2013-06-24 02:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-04 03:55:19 UTC


Attachments (Terms of Use)

Description Doug Ledford 2008-06-14 16:48:41 UTC
If a bug exists against component A and a developer sets the pc ack flag to ?,
and that component is already on the approved list, the bugbot sets the pm ack
flag to +.  If the component of the bug is then later changed to something that
isn't already approved, bugzilla should set the pm ack flag to ? when changing
the component.  It doesn't and as a result we end up with a bug against a non
approved component with the pm ack flag set to +.  When I changed bug 249246
from openib to librdmacm is an example of how/when this can happen.

Comment 1 Noura El hawary 2008-06-15 01:07:58 UTC
Hi Doug,

are you reporting this issue against the production bugzilla bugzilla.redhat.com
,,, or against the new 3.2 bugzilla on 
partner-bugzilla.redhat.com ?

Noura

Comment 2 Doug Ledford 2008-06-15 04:49:55 UTC
The production bugzilla...I wasn't sure what version it was and just assumed it
was the latest.

Comment 3 David Lawrence 2008-09-16 16:56:21 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 4 Noura El hawary 2008-12-02 04:23:47 UTC
Hi Doug,

There isn't currently any mapping between the pm_ack flag and any bug field changes in bugzilla, flags gets manually set by bugzilla users who are authorized to do so, so should there be an automatic mapping? Is that a feature request by Product Management to be added to bugzilla?

Noura

Comment 5 Noura El hawary 2009-02-04 03:55:19 UTC
This is not a bug, so closing it, please reopen it if you would consider it a new feature request.


Note You need to log in before you can comment on or make changes to this bug.