Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451444 - wifi lenovo n200 (intel bgn 4965)dont work and dont start automatic
Summary: wifi lenovo n200 (intel bgn 4965)dont work and dont start automatic
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 451443 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 16:35 UTC by A
Modified: 2009-02-14 20:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-14 20:39:22 UTC


Attachments (Terms of Use)

Description A 2008-06-14 16:35:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
when i doing updating after that the the network dont powerup the wifi lenovo n200 intel 4965

dont connect


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1.install new kernel
2.setup the confiure of the wifi (intel bgn 4965)
3.the kernel work fine (not best) only on version 2.6.25.3-18.fc9.i686 

Actual Results:


Expected Results:


Additional info:

Comment 1 Dan Williams 2008-11-02 22:11:33 UTC
*** Bug 451443 has been marked as a duplicate of this bug. ***

Comment 2 Sven Neuhaus 2008-12-07 18:43:01 UTC
Works out of the box with Fedora 10 and kernel 2.6.27.5-117.fc10.x86_64

lspci shows:
04:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)


Here are the kernel messages during boot:
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27kds
iwlagn: Copyright(c) 2003-2008 Intel Corporation
iwlagn 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:04:00.0: setting latency timer to 64
iwlagn: Detected Intel Wireless WiFi Link 4965AGN REV=0x4
iwlagn: Tunable channels: 13 802.11bg, 19 802.11a channels
iwlagn 0000:04:00.0: PCI INT A disabled
phy0: Selected rate control algorithm 'iwl-agn-rs'
...
ADDRCONF(NETDEV_UP): eth0: link is not ready
iwlagn 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:04:00.0: restoring config space at offset 0x1 (was 0x40100102, writing 0x40100106)
firmware: requesting iwlwifi-4965-2.ucode
Registered led device: iwl-phy0:radio
Registered led device: iwl-phy0:assoc
Registered led device: iwl-phy0:RX
Registered led device: iwl-phy0:TX
ADDRCONF(NETDEV_UP): wlan0: link is not ready
...
wlan0: authenticate with AP xx:xx:xx:xx:xx
wlan0: authenticated
wlan0: associate with AP xx:xx:xx:xx:xx
wlan0: RX AssocResp from xx:xx:xx:xx:xx (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present


It even works with suspend/resume! Great work.

Comment 3 Dan Williams 2009-02-14 20:39:22 UTC
thanks for the report, closing.  In general, updated kernels will fix wifi and suspend/resume issues as they are fixed upstream, and NM obviously benefits from those.


Note You need to log in before you can comment on or make changes to this bug.