Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451440 - Crash when use giomm file enumerator
Summary: Crash when use giomm file enumerator
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibmm24
Version: 9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Denis Leroy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 15:44 UTC by Kamil Pawlowski
Modified: 2008-06-24 08:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 08:25:14 UTC


Attachments (Terms of Use)

Description Kamil Pawlowski 2008-06-14 15:44:37 UTC
Description of problem:
Something is wrong with glib/glibmm

Version-Release number of selected component (if applicable):
glibmm24-devel-2.16.0-1.fc9.x86_64
glib2-devel-2.16.3-5.fc9.x86_64

How reproducible:
Compile and run this:
RefPtr<Cancellable> cancellable = Cancellable::create();
RefPtr<File> pluginsDir = File::create_for_path(PACKAGE_PLUGINS_DIR);
RefPtr<FileEnumerator> fileEnumerator =
pluginsDir->enumerate_children(cancellable, "*.so");
RefPtr<FileInfo> fileInfo;
while ((fileInfo = fileEnumerator->next_file()) != NULL) {
	std::cout << "check: " << fileInfo->get_name() << std::endl;
}

Actual results:
glibmm-WARNING **: failed to wrap type of 'GLocalFileEnumerator'
after this, crush when use file enumerator

Expected results:
read contents of directory

Additional info:

Comment 1 Denis Leroy 2008-06-18 07:45:59 UTC
Could you reproduce with glibmm24 2.16.2 ? (currently available as a F-9 stable
update).


Comment 2 Kamil Pawlowski 2008-06-23 23:05:58 UTC
With 2.16.2 I have the same error as 2.16.0

Comment 3 Denis Leroy 2008-06-24 07:16:17 UTC
Looks like you forgot to call "Gio::init()".


Comment 4 Kamil Pawlowski 2008-06-24 08:18:17 UTC
Thats it, sorry I forgot, now giomm wrap correctly


Note You need to log in before you can comment on or make changes to this bug.