Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451438 - Adobe Flash plugin needs to be in /usr/lib/mozilla/plugins
Summary: Adobe Flash plugin needs to be in /usr/lib/mozilla/plugins
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 15:18 UTC by Joachim Frieben
Modified: 2018-04-11 09:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 06:02:48 UTC


Attachments (Terms of Use)

Description Joachim Frieben 2008-06-14 15:18:43 UTC
Description of problem:
Adobe Flash plugin does neither work when located in $HOME/.mozilla/plugins
nor in /usr/lib/xulrunner-1.9pre/plugins.

Version-Release number of selected component (if applicable):
epiphany-2.22.2-1.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Copy libflashplayer.so* to $HOME/.mozilla/plugins.
2. Open http://www.adobe.com/shockwave/welcome in epiphany.
 
Actual results:
A grey rectangle appears in the test field.

Expected results:
Adobe test animation is played.

Additional info:
- presence/absence of nspluginwrapper has no effect.
- installing libflashplayer.so* in /usr/lib/mozilla/plugins allows to
  restore correct Flash operation.

Comment 1 Joachim Frieben 2008-06-14 15:20:21 UTC
In all cases, "about:plugins" does reports presence and version of Adobe
Flash correctly.

Comment 2 Matěj Cepl 2008-06-14 19:22:34 UTC
Could you please provide us with the output of this command

rpm -qa \*mozilla\* \*plugin\* \*firefox\* \*flash\*

Thank you.

Comment 3 Joachim Frieben 2008-06-15 09:34:27 UTC
The output reads:

 alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
 gstreamer-plugins-base-0.10.19-2.fc9.i386
 gstreamer-plugins-good-0.10.8-5.fc9.i386
 gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
 java-1.6.0-openjdk-plugin-1.6.0.0-0.15.b09.fc9.i386
 libflashsupport-000-0.5.svn20070904.i386
 maven-shared-plugin-testing-harness-1.0-4jpp.4.fc9.i386
 mozilla-filesystem-1.9-2.fc9.i386
 nspluginwrapper-0.9.91.5-27.fc9.i386
 setroubleshoot-plugins-2.0.4-5.fc9.noarch
 totem-mozplugin-2.23.2-2.fc9.i386

Adobe Flash is not installed as RPM, instead libflashplayer.so* is
copied to the various locations.

Comment 4 Matěj Cepl 2008-06-15 19:03:53 UTC
Try to eliminate libflashplayer.so and install RPM (or even better yum repo).
Does it help?

Comment 5 Joachim Frieben 2008-06-16 11:33:37 UTC
Not surprisingly, it does. In this case, libflashplayer.so* is again
installed in /usr/lib/mozilla/plugins which already worked before.
The point of this report is that epiphany/xulrunner have to be able to
use plugins in the user's home directory, too. Right now, the Flash
plugin is recognized but not used. /usr/lib/xulrunner-1.9pre should do
the job, too.
Actually, this problem is the opposite of a an issue that I had reported
in the past, namely bug 427369. It seems as if something else got broken
in the attempt to cure the previous misbehaviour.

Btw, additional package information is:
xulrunner-1.9-0.60.beta5.fc9.i386

Comment 6 Martin Stransky 2008-06-17 06:02:48 UTC
The only correct location for mozilla plug-ins is /usr/lib/mozilla/plugins. All
others are unsupported.


Note You need to log in before you can comment on or make changes to this bug.