Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451431 - preupgrade hangs in final stage
Summary: preupgrade hangs in final stage
Keywords:
Status: CLOSED DUPLICATE of bug 446237
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 12:55 UTC by Tobias
Modified: 2008-10-20 18:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-20 18:44:30 UTC


Attachments (Terms of Use)

Description Tobias 2008-06-14 12:55:40 UTC
Description of problem:
When trying to upgrade from Fedora 8 to 9 preupgrade hangs in the last stage.
The gui does not respond. The last output on the console is:
DEBUG /sbin/grubby --title="Upgrade to Fedora 9 (Sulphur)"
--add-kernel=/boot/upgrade/vmlinuz --initrd=/boot/upgrade/initrd.img
--args="preupgrade lang=en_US.UTF-8 keymap=de
stage2=hd:sda1:boot/upgrade/stage2.img
method=http://ftp.uni-koeln.de/mirrors/fedora/linux/releases/9/Fedora/i386/os"
Probing devices to guess BIOS drives. This may take a long time.

I have waited for several hours without result.

Version-Release number of selected component (if applicable):
Name        : preupgrade                   Relocations: (not relocatable)
Version     : 0.9.3                             Vendor: Fedora Project
Release     : 3.fc8                         Build Date: Tue 13 May 2008 09:27:38
PM CEST
Install Date: Fri 13 Jun 2008 10:45:19 PM CEST      Build Host:
ppc3.fedora.redhat.com


How reproducible:
always

Steps to Reproduce:
1. start preupgrade
2. let it run till downloading images stage 2
3. preupgrade does not respond anymore
  
Actual results:
program hangs

Expected results:
preupgrade should show "reboot now" button

Additional info:
my smolt profile:
http://www.smolts.org/client/show/pub_bf2e9418-c642-401d-99e3-9f99aafe97a7

Comment 1 Vince Schiavoni 2008-10-20 18:29:11 UTC
Confirmed for F8=>F9 preupgrade-0.9.3-3.fc8.noarch, exact same results as described above.

Priority may be "low" but severity should be "high" IMHO since this is a show-stopper for preupgrade.

Regards,
VJS

Comment 2 Will Woods 2008-10-20 18:44:30 UTC
Preupgrade-0.9.8 fixes this, but it only supports upgrading to F10 Beta or Rawhide. You'll be able to preupgrade F8/F9 to F10 Final once it's released.

The problems with preupgrades to F-9 are, unfortunately, not fixable.

*** This bug has been marked as a duplicate of bug 446237 ***


Note You need to log in before you can comment on or make changes to this bug.