Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451427 - Startup of setroubleshootd fails and connection to it denied
Summary: Startup of setroubleshootd fails and connection to it denied
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 9
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: John Dennis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 11:52 UTC by Stefan Schulze Frielinghaus
Modified: 2008-07-09 02:43 UTC (History)
0 users

Fixed In Version: 2.0.8-2.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 19:20:33 UTC


Attachments (Terms of Use)

Description Stefan Schulze Frielinghaus 2008-06-14 11:52:34 UTC
Description of problem:
When setroubleshootd is started the following error message is generated in the
logfile:

2008-06-14 13:43:09,315 [rpc.ERROR] exception TypeError: not all arguments
converted during string formatting
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/setroubleshoot/rpc.py", line 940, in
handle_client_io
    self.receiver.feed(data)
  File "/usr/lib/python2.5/site-packages/setroubleshoot/rpc.py", line 762, in feed
    self.process()
  File "/usr/lib/python2.5/site-packages/setroubleshoot/rpc.py", line 754, in
process
    self.dispatchFunc(self.header, self.body)
  File "/usr/lib/python2.5/site-packages/setroubleshoot/rpc.py", line 978, in
default_request_handler
    return_args = method_ptr(*args)
  File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 251, in
logon
    raise ProgramError(ERR_USER_LOOKUP, detail="uid=s does not match logon
username (%s)" % (self.uid, username))
TypeError: not all arguments converted during string formatting
2008-06-14 13:43:09,321 [rpc.WARNING] remove_client: client (channel: name=None
addr={unix}/var/run/setroubleshoot/setroubleshoot_server socket=None
type=sealert) not in client pool

Also if I try to connect to the daemon via "/usr/bin/sealert -b" (ak. SELinux
Troubleshooter) the same error message is generated in the logfile and the GUI
just says "connection lost to /var/run/setroubleshoot/setroubleshoot_server"


Version-Release number of selected component (if applicable):
2.0.6-1.fc9

Steps to Reproduce:
Just restart or connect to setroubleshootd

Comment 1 John Dennis 2008-06-15 18:08:27 UTC
I'm pretty sure this is a dup of bug 446661 which only occurs on PPC.

For a quick test of that theory edit
/usr/lib/python2.5/site-packages/setroubleshoot/access_control.py

and change SO_PEERCRED from 17 to 21

Comment 2 John Dennis 2008-06-15 18:12:38 UTC
Or you could try installing 2.0.7.1 which has the bug fix, but this hasn't been
pushed out yet, but you can download it from:

http://koji.fedoraproject.org/koji/buildinfo?buildID=49322

Comment 3 Fedora Update System 2008-06-16 18:21:19 UTC
setroubleshoot-2.0.7-1.fc9 has been submitted as an update for Fedora 9

Comment 4 Stefan Schulze Frielinghaus 2008-06-17 18:03:11 UTC
Version 2.0.7-1.fc9 didn't fix the problem. But I noticed another error message.
When I manually restart the daemon the following is returned to terminal:

$ /etc/init.d/setroubleshoot restart
Stopping setroubleshootd:                                  [  OK  ]
Starting setroubleshootd:                                  [  OK  ]
$ Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 221, in
on_connection_state_change
    self.uid, self.gid = self.access.get_credentials(self.socket_address.socket)
  File "/usr/lib/python2.5/site-packages/setroubleshoot/access_control.py", line
142, in get_credentials
    if family != socket.AF_UNIX:
NameError: global name 'socket' is not defined

The message in logfile is still the same.

Comment 5 John Dennis 2008-06-17 18:08:48 UTC
setroubleshoot-2.0.8-1.fc9 was pushed to updates-testing this morning to correct
this (a capitalization typo, it should have been 'Socket' not 'socket').

Comment 6 Stefan Schulze Frielinghaus 2008-06-17 18:31:34 UTC
In the spec file of setroubleshoot-2.0.8-1.fc9 is another typo.

Line 22:

Requires: libxml2-pythonRequires(post):   /usr/bin/update-desktop-database

Should be:

Requires: libxml2-python
Requires(post):   /usr/bin/update-desktop-database

Comment 7 Fedora Update System 2008-06-17 19:08:55 UTC
setroubleshoot-2.0.8-2.fc9 has been submitted as an update for Fedora 9

Comment 8 John Dennis 2008-06-17 19:09:06 UTC
Thank you! Must be my day for silly editing mistakes :-)
setroubleshoot-2.0.8-2.fc9 fixes the deleted line break. Pushed to updates-testing.

Comment 9 Stefan Schulze Frielinghaus 2008-06-17 19:20:33 UTC
Perfect, that version did it ;-)

I really missed setroubleshoot over the last weeks. It's a real nice app!

Comment 10 Fedora Update System 2008-07-09 02:43:46 UTC
setroubleshoot-2.0.8-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.