Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451426 - PDF files cannot be printed
Summary: PDF files cannot be printed
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 11:43 UTC by antonio montagnani
Modified: 2008-09-01 12:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-01 10:43:40 UTC


Attachments (Terms of Use)
Test PDF file (deleted)
2008-06-14 11:43 UTC, antonio montagnani
no flags Details
Troubleshooting file for Samsung printer (deleted)
2008-06-15 05:53 UTC, antonio montagnani
no flags Details
ML-1610 ppd file (deleted)
2008-06-16 19:53 UTC, antonio montagnani
no flags Details
Output of line command (deleted)
2008-07-04 05:16 UTC, antonio montagnani
no flags Details

Description antonio montagnani 2008-06-14 11:43:06 UTC
Description of problem:
I cannot print PDF file on my Epsom ML-1600 printer

Version-Release number of selected component (if applicable):
cups-1.3.7-2.fc9.i386

How reproducible:
always

Steps to Reproduce:
1.print a PDF file
2.
3.
  
Actual results:
Error on printer

Expected results:
print

Additional info:

Comment 1 antonio montagnani 2008-06-14 11:43:06 UTC
Created attachment 309356 [details]
Test PDF file

Comment 2 Tim Waugh 2008-06-14 17:31:46 UTC
> Error on printer

Please be much more descriptive than this.  What error?  Is there an error
message, an error code?  Does anything print?

I'm confused about which model of printer it is.  Epson doesn't make a model
called 'ML-1600' as far as I'm aware, but Samsung does.

It would help if you try troubleshooting this problem yourself first by
selecting System->Administration->Printing from the main menu, then
Help->Troubleshoot from the menu in the printer configuration tool.  This will
check for simple problems and gather information for further diagnosis -- attach
the troubleshoot.txt file as an attachment to this bug report.

Comment 3 antonio montagnani 2008-06-15 05:53:42 UTC
Created attachment 309387 [details]
Troubleshooting file for Samsung printer

Comment 4 antonio montagnani 2008-06-15 05:57:12 UTC
(In reply to comment #3)
> Created an attachment (id=309387) [edit]
> Troubleshooting file for Samsung printer
> 

1) Printer is Samsung
2) It works fine on regular documents, but on this one and similar when I print,
lights on printer turn from green to flashing red, and if I go to see the queue
document remains in progress.
3) I could print on same printer connected to Fedora from a networked Vista laptop

Comment 5 Tim Waugh 2008-06-16 08:48:45 UTC
Please attach /etc/cups/ppd/ML-1610.ppd.

Comment 6 antonio montagnani 2008-06-16 19:53:47 UTC
Created attachment 309528 [details]
ML-1610 ppd file

Please note that if I say that I want 300 dpi in config-system-printer I cannot
print the test page, I have to use the 600 dpi option

Comment 7 Tim Waugh 2008-06-19 08:31:29 UTC
But does setting the resolution to 300dpi allow this particular document to be
printed?  In other words, does this work?

lp -oResolution=300x300dpi -dML-1610 dann01.pdf

Comment 8 antonio montagnani 2008-07-04 05:16:58 UTC
Created attachment 310993 [details]
Output of line command

it is exactly what I get either from command line or system-config-printer.
Sorry dor the delay

Comment 9 antonio montagnani 2008-08-30 09:55:33 UTC
Situation is very bad, now I can't print from any application in rawhide (Gimp, Openoffice, Adobe...)
I do not see any improvement in printing, shall I sell my SAMSUNG and switch to a HP laser printer :-( ????.

And I notice that the only available driver is gdi.

Comment 10 Tim Waugh 2008-09-01 10:43:40 UTC
The only other choice you have for this printer is to use the splix driver.  Unfortunately we are not able to ship this driver in Fedora due to patent issues.

Comment 11 antonio montagnani 2008-09-01 12:59:06 UTC
Tnx Tim.
I will try the splix driver, that in F7 was going to be packaged...and it was included in the available driver list.


Note You need to log in before you can comment on or make changes to this bug.