Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451420 - Compiler crash with gcc 4.3.0
Summary: Compiler crash with gcc 4.3.0
Keywords:
Status: CLOSED DUPLICATE of bug 440139
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 11:08 UTC by Chris Rankin
Modified: 2008-06-15 22:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-15 22:39:44 UTC


Attachments (Terms of Use)

Description Chris Rankin 2008-06-14 11:08:37 UTC
Description of problem:
When trying to compile wine from git:

make[2]: Entering directory `/home/chris/Programs/wine/dlls/user32/tests'
gcc -c -I. -I. -I../../../include -I../../../include   -D_REENTRANT -fPIC -Wall
-pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings
-Wtype-limits -Wpointer-arith  -g -O2  -o menu.o menu.c
{standard input}: Assembler messages:
{standard input}:7412: Warning: end of file not at end of a line; newline inserted
{standard input}:7745: Error: unknown pseudo-op: `.l'
gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <http://bugzilla.redhat.com/bugzilla> for instructions.
make[2]: *** [menu.o] Error 1
make[2]: Leaving directory `/home/chris/Programs/wine/dlls/user32/tests'
make[1]: *** [user32/tests] Error 2
make[1]: Leaving directory `/home/chris/Programs/wine/dlls'
make: *** [dlls] Error 2


Version-Release number of selected component (if applicable):
gcc 4.3.0 20080428 (Red Hat 4.3.0-8)

How reproducible:
gcc crashes every time I try to compile this file.

Steps to Reproduce:
1. Download wine from git (2008-06-14)
2. ./configure
3. make depend && make
  
Actual results:
gcc crashes when trying to compile wine/dlls/user32/tests/menu.c

Expected results:
menu.o

Additional info:

Comment 1 Chris Rankin 2008-06-14 11:19:18 UTC
$ file core.12885
core.12885: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style,
from '/usr/libexec/gcc/i386-redhat-linux/4.3.0/cc1 -quiet -I. -I.
-I../../../include'

The compiler is crashing while generating menu.s.

Comment 2 Jakub Jelinek 2008-06-15 22:39:44 UTC

*** This bug has been marked as a duplicate of 440139 ***


Note You need to log in before you can comment on or make changes to this bug.