Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451414 - full screen OpenGL apps crash
Summary: full screen OpenGL apps crash
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 9
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-14 10:04 UTC by Alec Leamas
Modified: 2018-04-11 08:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-14 12:05:07 UTC


Attachments (Terms of Use)
xorg.conf (deleted)
2008-06-14 10:06 UTC, Alec Leamas
no flags Details
glxinfo output (deleted)
2008-06-14 10:08 UTC, Alec Leamas
no flags Details
X server log file Xorg.0.log (deleted)
2008-06-14 10:11 UTC, Alec Leamas
no flags Details

Description Alec Leamas 2008-06-14 10:04:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
Full screen OpenGL applicatiomns like google earth causes a xorg/kernel crash at startup. 

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.4.99.902-3.20080612.fc9.x86_64

How reproducible:
Always


Steps to Reproduce:
1.Start google earth or openarena.
2.In openarena case, start the (single player) game
3.See system crash: black screen direct or possibly a second after first full screen display.

Actual Results:
Crash. System unresponsive. No virtual terminal or new ssh connections. Occasionally, existing ssh connections gives a prompt back, but doesn't even handle reboot command.  

No fun.

Expected Results:
No crash, working application, lots of fun.

Additional info:
My hardware is a ASUS m2n32 ws pro mobo, AMD X2, nvidia GT6600 card. BIOS is updated to vers 2001, latest as of today.

This is a longstanding issue which was introduced sometime when I upgraded FC-8. The original FC8 did not have this problem.

As for the sys req reboot, this was the first time I tried to use this, and all kind of errors from my side are thus possible.

To my understanding, the driver works fine otherwise including desktop effects, video etc. Glxgears works also ok, even if I stress the  card by maximizing it to cover the whole screen. For what is worth, there are no known problems with the pulseaudio sound either.

Part of the problem is that the nvidia driver is used (I have to,there is no alternative 3D driver for my GT6600 card). However, googling around I feel that I'm not alone in this; see http://forums.fedoraforum.org/showthread.php?t=180743, bug 229624 which possibly are related (there is more out there). Rumour is that certain combinations of motherboard, processor and graphics card triggers a kernel bug.

According to http://www.nvnews.net/vbulletin/showthread.php?t=58498 I have tried the kernel parameters maxcpus=1, idle=poll and pci=nommconf without any visible effects. 
This is also reported as http://www.nvnews.net/vbulletin/showthread.php?t=114492.

Comment 1 Alec Leamas 2008-06-14 10:06:22 UTC
Created attachment 309341 [details]
xorg.conf

Also tried with an empty xorg.conf (besides "driver; nvidia"), same result.

Comment 2 Alec Leamas 2008-06-14 10:08:56 UTC
Created attachment 309342 [details]
glxinfo output

Comment 3 Alec Leamas 2008-06-14 10:11:09 UTC
Created attachment 309343 [details]
X server log file Xorg.0.log

Comment 4 Matěj Cepl 2008-06-14 12:05:07 UTC
I am really sorry, but we really cannot deal with the binary-only drivers
(especially their beta versions). If you would be able to reproduce this issue
using only open source software, please, reopen this bug with the additional
information, but in meantime I have no choice than to close this bug as CANTFIX
(because we really cannot fix it).


Note You need to log in before you can comment on or make changes to this bug.