Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451387 - multilib conflicts in postgis package
Summary: multilib conflicts in postgis package
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: postgis
Version: 9
Hardware: powerpc
OS: Linux
low
medium
Target Milestone: ---
Assignee: Devrim GUNDUZ
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 23:07 UTC by Thiago Jung Bauermann
Modified: 2008-09-10 07:13 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-13 20:09:31 UTC


Attachments (Terms of Use)

Description Thiago Jung Bauermann 2008-06-13 23:07:15 UTC
Description of problem:

It is not possible to install the .ppc.rpm and the .ppc64.rpm packages of
postgis at the same time, because of file conflicts. This affects me on the
PowerPC platform, but I believe it will also be a problem in x86_64 which is
also a biarch architecture.

Version-Release number of selected component (if applicable):

postgis-1.3.3-1.fc9

How reproducible:

Always

Steps to Reproduce:
1. Grab postgis-1.3.3-1.fc9.ppc.rpm and postgis-1.3.3-1.fc9.ppc64.rpm from the
Everything repository
2. sudo rpm -ivh postgis-1.3.3-1.fc9.ppc.rpm postgis-1.3.3-1.fc9.ppc64.rpm
  
Actual results:

  file /usr/share/pgsql/contrib/lwpostgis.sql from install of
postgis-1.3.3-1.fc9.ppc conflicts with file from package postgis-1.3.3-1.fc9.ppc64
  file /usr/share/pgsql/contrib/lwpostgis_upgrade.sql from install of
postgis-1.3.3-1.fc9.ppc conflicts with file from package postgis-1.3.3-1.fc9.ppc64

Expected results:

Successful installation of both packages.

Comment 1 Toshio Ernie Kuratomi 2008-06-14 17:30:59 UTC
It looks like the problem files do need to differ (because they are referencing
the modules located in /usr/lib64 or /usr/lib).  So the best method of dealing
with this is probably to rename them in the spec file.  Something like this at
the end of install should work::

if [ "%{_libdir}" = "/usr/lib64" ] ; then
    mv %{buildroot}%{_datadir}/pgsql/contrib/lwpostgis.sql
%{buildroot}%{_datadir}/pgsql/contrib/lwpostgis-64.sql
    mv %{buildroot}%{_datadir}/pgsql/contrib/lwpostgis_upgrade.sql
%{buildroot}%{_datadir}/pgsql/contrib/lwpostgis_upgrade-64.sql
fi

Note that I haven't tested that thoroughly as I don't have an x86_64 at the moment.

Comment 2 Devrim GUNDUZ 2008-08-11 08:18:55 UTC
I will take a look at this tonight. sorry for the delay.

Comment 3 Devrim GUNDUZ 2008-08-11 21:02:49 UTC
Ok, pushed to -devel and back branches.

Comment 4 Fedora Update System 2008-08-11 21:14:26 UTC
postgis-1.3.3-2.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-08-11 21:15:38 UTC
postgis-1.3.3-2.fc8 has been submitted as an update for Fedora 8

Comment 6 Thiago Jung Bauermann 2008-08-13 19:57:11 UTC
Hi,

I just verified the fix:

% sudo rpm -ivh postgis-1.3.3-2.fc9.ppc*
Preparing...                ########################################### [100%]
   1:postgis                ########################################### [ 50%]
   2:postgis                ########################################### [100%]
% rpm -qa | grep postgis
postgis-1.3.3-2.fc9.ppc64
postgis-1.3.3-2.fc9.ppc

Thanks!

Comment 7 Devrim GUNDUZ 2008-08-13 20:09:31 UTC
Thanks. I am now closing this bug.

Comment 8 Fedora Update System 2008-09-10 06:47:12 UTC
postgis-1.3.3-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-09-10 07:13:01 UTC
postgis-1.3.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.