Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451349 - update to 1.2.1-2.20080605git.fc9 messed up on X1200
Summary: update to 1.2.1-2.20080605git.fc9 messed up on X1200
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-radeonhd
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Hans Ulrich Niedermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 20:47 UTC by Pekka Savola
Modified: 2008-11-29 11:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-29 11:53:56 UTC


Attachments (Terms of Use)
differences between non-working ("Xorg.0.log.old") and working (Xorg.0.log) log file. (deleted)
2008-06-13 20:47 UTC, Pekka Savola
no flags Details
new xorg log diff (deleted)
2008-06-14 05:16 UTC, Pekka Savola
no flags Details
screenshot of a messed-up screen (deleted)
2008-06-14 05:17 UTC, Pekka Savola
no flags Details
diffs between the working git tree from april compared to 20080622git. (deleted)
2008-06-24 12:36 UTC, Pekka Savola
no flags Details


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 16347 None None None Never

Description Pekka Savola 2008-06-13 20:47:02 UTC
Description of problem:
I have X1200 series radeonhd card which, so far, has worked fine.
After upgrading the driver from
xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git.fc9.i386 to 
1.2.1-2.20080605git.fc9, when the X server is restarted, the screen gets messed
up in a strange way.  Because there are also strange messages in syslog, it is
probably not required to try to describe this further.  Downgrading the driver
version restores working behaviour.

Version-Release number of selected component (if applicable):
xorg-x11-drv-radeonhd i386 1.2.1-2.20080605git.fc9

How reproducible:
1.2.1-2.20080605git.fc9

Steps to Reproduce:
1. upgrade from 1.2.1-1.1.20080429git.fc9.i386 to 1.2.1-1.1.20080429git.fc9.i386
2. restart X server
3.
  
Additional info:
Attached is a diff of working vs non-working Xorg.0.log.

Comment 1 Pekka Savola 2008-06-13 20:47:02 UTC
Created attachment 309294 [details]
differences between non-working ("Xorg.0.log.old") and working (Xorg.0.log) log file.

Comment 2 Hans Ulrich Niedermann 2008-06-13 21:38:44 UTC
I would guess that xorg-x11-drv-radeonhd-1.2.1-2.20080613git.fc9.i386 aka
http://koji.fedoraproject.org/koji/buildinfo?buildID=52594 fixes this.

Could you please check that? Thanks a lot.


Comment 3 Fedora Update System 2008-06-13 21:45:47 UTC
xorg-x11-drv-radeonhd-1.2.1-2.20080613git.fc9 has been submitted as an update for Fedora 9

Comment 4 Pekka Savola 2008-06-14 05:15:59 UTC
Unfortunately, this doesn't help.  I've attached a new screenshot and a new xorg
log diff.  It appears that the fix in the package didn't work in this case
because there are still "Failed to set up write-combining range" messages.

Note: I'm not 100% sure if the diffs of xorg logs were correct because there was
some confusion about the VTYs but I hope so.

Note: I'll be on vacation for 1.5 weeks, unable to test new builds.


Comment 5 Pekka Savola 2008-06-14 05:16:45 UTC
Created attachment 309324 [details]
new xorg log diff

Comment 6 Pekka Savola 2008-06-14 05:17:31 UTC
Created attachment 309325 [details]
screenshot of a messed-up screen

Comment 7 Hans Ulrich Niedermann 2008-06-14 09:03:07 UTC
For anyone reading the log file diffs:

45fdec79: xorg-x11-drv-radeonhd-1.2.1-1.1.20080429git
26ccf117: xorg-x11-drv-radeonhd-1.2.1-2.20080605git
ad59f09e: xorg-x11-drv-radeonhd-1.2.1-2.20080613git


Comment 8 Hans Ulrich Niedermann 2008-06-14 11:16:40 UTC
Reported upstream as https://bugs.freedesktop.org/show_bug.cgi?id=16347

I suggest we wait for feedback from upstream, and if that does not help, have
you do a git-bisect when you're back from vacations.


Comment 9 Fedora Update System 2008-06-18 10:58:51 UTC
xorg-x11-drv-radeonhd-1.2.1-3.1.20080618git.fc9 has been submitted as an update for Fedora 9

Comment 10 Fedora Update System 2008-06-20 19:05:48 UTC
xorg-x11-drv-radeonhd-1.2.1-3.1.20080618git.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-radeonhd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5457

Comment 11 Fedora Update System 2008-06-22 17:39:03 UTC
xorg-x11-drv-radeonhd-1.2.1-3.2.20080622git.fc9 has been submitted as an update for Fedora 9

Comment 12 Pekka Savola 2008-06-24 12:33:43 UTC
The updates seem don't seem to have gone to updates or updates-testing, but from
koji, I tested xorg-x11-drv-radeonhd-1.2.1-3.2.20080622git.fc9.i386.rpm.

Unfortunately, it doesn't fix the problems for me, but instead of a garbled
screen, I get a completely white screen.  I'll attach an xorg.log diff  if it helps.

Comment 13 Pekka Savola 2008-06-24 12:36:18 UTC
Created attachment 310135 [details]
diffs between the working git tree from april compared to 20080622git.

Comment 14 Fedora Update System 2008-06-25 02:53:17 UTC
xorg-x11-drv-radeonhd-1.2.1-3.2.20080622git.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-radeonhd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-5672

Comment 15 Pekka Savola 2008-07-09 21:56:15 UTC
FYI: xorg-x11-drv-radeonhd-1.2.1-3.3.20080630git.fc9.i386 fixed this for me.

Most interesting diffs compared to git0622 seem to be (note that xorg version
had a minor update during this interval as well):


-(II) RADEONHD(0): Mapped IO at 0xb7ffe000 (size 0x00010000)
+(II) RADEONHD(0): Mapped IO at 0xb80a8000 (size 0x00010000)
...
-(II) RADEONHD(0): Mapped IO at 0xb7ffe000 (size 0x00010000)
+(II) RADEONHD(0): Mapped IO at 0xb80a8000 (size 0x00010000)
-(WW) RADEONHD(0): IGP memory base 0x08c69c90 seems to be bogus.
-(==) RADEONHD(0): Not Mapping IGP memory
-(II) RADEONHD(0): Mapped FB at 0xa7fed000 (size 0x10000000)
+(==) RADEONHD(0): Mapping IGP memory @ 0x30000000
+(==) RADEONHD(0): Write-combining range (0x30000000,0x10000000)
+(II) RADEONHD(0): Mapped FB at 0xa8097000 (size 0x10000000)
...
-(II) Loading sub module "GLcore"
-(II) LoadModule: "GLcore"
-
-(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
-(II) Module GLcore: vendor="X.Org Foundation"
-       compiled for 1.4.99.902, module version = 1.0.0
-       ABI class: X.Org Server Extension, version 1.0
-(II) GLX: Initialized MESA-PROXY GL provider for screen 0
+(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
+(II) GLX: Initialized DRISWRAST GL provider for screen 0






Comment 16 Hans Ulrich Niedermann 2008-07-13 18:32:56 UTC
Could you please test xorg-x11-drv-radeonhd-1.2.1-3.4.20080713git.fc9?

http://koji.fedoraproject.org/koji/taskinfo?taskID=712767


Comment 17 Fedora Update System 2008-07-13 18:34:44 UTC
xorg-x11-drv-radeonhd-1.2.1-3.4.20080713git.fc9 has been submitted as an update for Fedora 9

Comment 18 Pekka Savola 2008-07-13 18:44:12 UTC
Works fine, the same as 0630 git version.  No significant changes in Xorg.log.

Comment 19 Hans Ulrich Niedermann 2008-07-13 19:00:51 UTC
Awesome. Thanks a lot.

We finally might have a serious candidate for a new stable package.


Comment 20 Hans Ulrich Niedermann 2008-11-29 11:53:56 UTC
Appears fixed, closing bug. Thanks for the help.


Note You need to log in before you can comment on or make changes to this bug.