Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451345 - libsepol.a is missing from libsepol-devel
Summary: libsepol.a is missing from libsepol-devel
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: setools
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris PeBenito
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 20:42 UTC by John D. Ramsdell
Modified: 2008-06-16 13:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 10:36:09 UTC


Attachments (Terms of Use)

Description John D. Ramsdell 2008-06-13 20:42:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008060309 Firefox/3.0

Description of problem:
With libsepol-devel installed, the following autoconf script fails.

AC_CHECK_HEADERS([sepol/policydb.h],,
  AC_MSG_ERROR([libsepol headers missing]))

LIBS="-Wl,-dn -lsepol -Wl,-dy $LIBS"

AC_CHECK_FUNCS([policydb_read],,
  AC_MSG_ERROR([libsepol.a missing]))


It looks for libsepol.a, because libsepol.so does not export policydb_read.
[root@goo slat]# uname -a
Linux goo.mitre.org 2.6.25.4-30.fc9.i686 #1 SMP Wed May 21 18:12:35 EDT 2008 i6\
86 i686 i386 GNU/Linux
[root@goo slat]# yum install libsepol-devel
fedora                                                   | 2.4 kB     00:00    \

updates                                                  | 2.3 kB     00:00    \

Setting up Install Process
Parsing package install arguments
Package libsepol-devel-2.0.26-1.fc9.i386 already installed and latest version
Nothing to do
[root@goo slat]# ls -l /usr/lib/libsepol.a
ls: cannot access /usr/lib/libsepol.a: No such file or directory
[root@goo slat]#






Version-Release number of selected component (if applicable):
libsepol-devel-2.0.26-1.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1.yum install libsepol-devel
2.ls -l /usr/lib/libsepol.a


Actual Results:
ls: cannot access /usr/lib/libsepol.a: No such file or directory

Expected Results:
The file should have been there.

Additional info:

Comment 1 Daniel Walsh 2008-06-16 10:36:09 UTC
Install libsepol-static.

Comment 2 John D. Ramsdell 2008-06-16 13:20:43 UTC
Thanks Dan.  I updated Slat's README to reflect this change.  FYI, I've been
asked the get slat working again.  I notice the binary interface has changed yet
again. Off to hack C code...


Note You need to log in before you can comment on or make changes to this bug.