Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451288 - tar error message when creating archives
Summary: tar error message when creating archives
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 18:24 UTC by Pedro Matiello
Modified: 2008-06-16 23:32 UTC (History)
0 users

Fixed In Version: 1.19-4.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 23:32:05 UTC


Attachments (Terms of Use)

Description Pedro Matiello 2008-06-13 18:24:11 UTC
Description of problem:
tar, as used by file-roller, outputs a error message when creating new files.
Despite that, the created archives seem to be ok.

Version-Release number of selected component (if applicable):
tar-1.19-3.fc9.i386

How reproducible:
Always.

Steps to Reproduce:
1. Create a tar.bz2 or tar.gz file with file-roller.

OR

1. Use the following command at the terminal:
$ tar --force-local --no-recursion --no-wildcards -v -p -C
/PATH/TO/FILE/TO/BE/ADDED -rf PATH/TO/ARCHIVE.tar
  
Actual results:
[pedro@spacelab ~]$ tar --force-local --no-recursion --no-wildcards -v -p -C
Workspace/ -rf Workspace.tar
tar: This does not look like a tar archive
tar: Error exit delayed from previous errors

Expected results:
No error message.

Additional info:
This is a upstream bug in tar. It seems to be already fixed, so updating to the
most recent version of tar should be enough.

Comment 1 Ondrej Vasik 2008-06-16 09:52:56 UTC
Thanks for report. Sorry, but update to tar-1.20 is almost impossible for F9 (as
some patches have to be heavily modified - I did that already for Rawhide
fedora, but it is not something what I would like to do in stable release). Will
try to find out upstream solution and possibly backport the patch to tar-1.19 . 

Comment 2 Pedro Matiello 2008-06-16 11:37:37 UTC
Thanks!

Comment 3 Ondrej Vasik 2008-06-16 11:57:48 UTC
Backported the fix, built as tar-1.19-4.fc9 (rpm available at
http://koji.fedoraproject.org/koji/taskinfo?taskID=663428 ) ... works ok on my
machine. Could you please test it on your machine before I push new tar to stable?

Comment 4 Fedora Update System 2008-06-16 12:08:29 UTC
tar-1.19-4.fc9 has been submitted as an update for Fedora 9

Comment 5 Pedro Matiello 2008-06-16 12:18:47 UTC
Installed the rpm here and it worked fine. No error message.

Thanks. :)

Comment 6 Fedora Update System 2008-06-16 23:32:03 UTC
tar-1.19-4.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.