Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451282 - iwl4965 driver causes kernel panic with Intel 4965AGN wireless
Summary: iwl4965 driver causes kernel panic with Intel 4965AGN wireless
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 17:45 UTC by Yuta Kitamura
Modified: 2008-06-13 23:43 UTC (History)
3 users (show)

Fixed In Version: 2.6.25.6-57.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-13 20:29:41 UTC


Attachments (Terms of Use)
Kernel panic log (deleted)
2008-06-13 17:46 UTC, Yuta Kitamura
no flags Details
dmesg information (deleted)
2008-06-13 17:48 UTC, Yuta Kitamura
no flags Details

Description Yuta Kitamura 2008-06-13 17:45:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
I'm using Panasonic CF-Y7 laptop which has Intel Wireless WiFi Link 4965 AGN wireless LAN card.
Since the update of the new Fedora kernel (kernel-2.6.25.6-55.fc9.i686),
the iwl4965 driver causes a kernel panic on wireless network activation (by using NetworkManager) and the system freezes completely.


Version-Release number of selected component (if applicable):
kernel-2.6.25.6-55.fc9.i686

How reproducible:
Always


Steps to Reproduce:
1. Start a wireless network by NetworkManager.


Actual Results:
The system became frozen by a kernel panic.

Expected Results:
The wireless network should have been successfully started.

Additional info:
Before the update of new kernel (i.e. kernel-2.6.25.4-30.fc9.i686 and before),
the wireless LAN worked fine.

Comment 1 Yuta Kitamura 2008-06-13 17:46:46 UTC
Created attachment 309264 [details]
Kernel panic log

The kernel panic log of this problem.

Comment 2 Yuta Kitamura 2008-06-13 17:48:44 UTC
Created attachment 309265 [details]
dmesg information

dmesg log of my system.

Comment 3 John W. Linville 2008-06-13 18:19:25 UTC
Does this happen every time?  Are you able to use the device for any time before
the crash?

Can you replicate the issue with the kernels here?

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52456

Comment 4 Yuta Kitamura 2008-06-13 19:01:51 UTC
(In reply to comment #3)
> Does this happen every time?  Are you able to use the device for any time before
> the crash?
> 
> Can you replicate the issue with the kernels here?
> 
>    http://koji.fedoraproject.org/koji/buildinfo?buildID=52456

This problem happens every time when I start a wireless network.
The system freezes after a wireless network is established by NetworkManager,
i.e. immediately after two green lamps get turned on.
Without starting a wireless network, the system seems to work fine
(but it will be started automatically when I use the laptop around the wireless
network registered to NetworkManager).

The problem does not seem to happen with the kernel shown above.
(Is this problem already fixed?)


Comment 5 John W. Linville 2008-06-13 20:29:41 UTC
It seems so...I think we are trying to get a new kernel through the normal
release process quickly.

Comment 6 Martin Ebourne 2008-06-13 20:41:19 UTC
I'm seeing the same issue on a HP 8510w also using iwl4965. Hard freeze just
after X started, which would correspond to NM bringing the network up.

Started with kernel-2.6.25.6-55.fc9.x86_64 (-30 was fine) and is already fixed
with kernel-2.6.25.6-57.fc9.x86_64.


Comment 7 Todd Savoie 2008-06-13 23:43:27 UTC
The kernel-2.6.25.6-57.fc9.x86_64 has resolve the same issue on my Compaq F730US
with a BCM94311MCG (b43)


Note You need to log in before you can comment on or make changes to this bug.