Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451237 - yum installs src.rpm in local dir not /usr/src, rpmdb has no paths for installed files
Summary: yum installs src.rpm in local dir not /usr/src, rpmdb has no paths for instal...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 15:49 UTC by Matthew Farrellee
Modified: 2014-01-21 23:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-13 20:56:12 UTC


Attachments (Terms of Use)

Description Matthew Farrellee 2008-06-13 15:49:07 UTC
Creating the SRPM

.../Fedora/condor/F-9 $ make srpm
rpmbuild --define "_sourcedir .../condor/F-9" --define "_specdir
.../Fedora/condor/F-9" --define "_builddir .../Fedora/condor/F-9" --define
"_srcrpmdir .../Fedora/condor/F-9" --define "_rpmdir .../Fedora/condor/F-9"
--define "dist .fc9" --define "fedora 9" --define "dist .fc9" --define "fedora
9" --nodeps -bs condor.spec
Wrote: .../Fedora/condor/F-9/condor-7.0.2-1.fc9.src.rpm
.../condor/F-9 $ scp condor-7.0.2-1.fc9.src.rpm root@dell-pe2900-03:

Installing the SRPM

[root@dell-pe2900-03 ~]# yum --nogpgcheck install condor-7.0.2-1.fc9.src.rpm 
Setting up Install Process
Parsing package install arguments
Examining condor-7.0.2-1.fc9.src.rpm: condor-7.0.2-1.fc9.src
Marking condor-7.0.2-1.fc9.src.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package condor.src 0:7.0.2-1.fc9 set to be updated
--> Processing Dependency: tcsh for package: condor
--> Processing Dependency: pcre-devel for package: condor
--> Processing Dependency: postgresql-devel for package: condor
--> Processing Dependency: gsoap-devel >= 2.7.10-2 for package: condor
--> Processing Dependency: classads-devel for package: condor
--> Running transaction check
---> Package gsoap-devel.i386 0:2.7.10-4.fc9 set to be updated
--> Processing Dependency: libgsoapssl.so.0 for package: gsoap-devel
--> Processing Dependency: libgsoapssl++.so.0 for package: gsoap-devel
--> Processing Dependency: libgsoapck++.so.0 for package: gsoap-devel
--> Processing Dependency: gsoap = 2.7.10-4.fc9 for package: gsoap-devel
--> Processing Dependency: libgsoap++.so.0 for package: gsoap-devel
--> Processing Dependency: libgsoapck.so.0 for package: gsoap-devel
--> Processing Dependency: libgsoap.so.0 for package: gsoap-devel
---> Package pcre-devel.i386 0:7.3-3.fc9 set to be updated
---> Package tcsh.i386 0:6.15-4.fc9 set to be updated
---> Package postgresql-devel.i386 0:8.3.3-1.fc9 set to be updated
--> Processing Dependency: libpgtypes.so.3 for package: postgresql-devel
--> Processing Dependency: libecpg_compat.so.3 for package: postgresql-devel
--> Processing Dependency: libpq.so.5 for package: postgresql-devel
--> Processing Dependency: libecpg.so.6 for package: postgresql-devel
--> Processing Dependency: postgresql = 8.3.3-1.fc9 for package: postgresql-devel
---> Package classads-devel.i386 0:1.0-1.fc9 set to be updated
--> Processing Dependency: libclassad.so.0 for package: classads-devel
--> Processing Dependency: classads = 1.0-1.fc9 for package: classads-devel
--> Processing Dependency: libclassad_ns.so.0 for package: classads-devel
--> Running transaction check
---> Package postgresql.i386 0:8.3.3-1.fc9 set to be updated
---> Package postgresql-libs.i386 0:8.3.3-1.fc9 set to be updated
---> Package gsoap.i386 0:2.7.10-4.fc9 set to be updated
---> Package classads.i386 0:1.0-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 condor                  src        7.0.2-1.fc9      condor-7.0.2-1.fc9.src.rpm
  12 M
Installing for dependencies:
 classads                i386       1.0-1.fc9        fedora            438 k
 classads-devel          i386       1.0-1.fc9        fedora            103 k
 gsoap                   i386       2.7.10-4.fc9     fedora            444 k
 gsoap-devel             i386       2.7.10-4.fc9     fedora            658 k
 pcre-devel              i386       7.3-3.fc9        fedora            488 k
 postgresql              i386       8.3.3-1.fc9      updates           3.4 M
 postgresql-devel        i386       8.3.3-1.fc9      updates           1.3 M
 postgresql-libs         i386       8.3.3-1.fc9      updates           213 k
 tcsh                    i386       6.15-4.fc9       fedora            473 k

Transaction Summary
=============================================================================
Install     10 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 19 M
Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: postgresql-libs              ####################### [ 1/10] 
  Installing: postgresql                   ####################### [ 2/10] 
  Installing: postgresql-devel             ####################### [ 3/10] 
  Installing: classads                     ####################### [ 4/10] 
  Installing: tcsh                         ####################### [ 5/10] 
  Installing: gsoap                        ####################### [ 6/10] 
  Installing: pcre-devel                   ####################### [ 7/10] 
  Installing: classads-devel               ####################### [ 8/10] 
  Installing: gsoap-devel                  ####################### [ 9/10] 

Installed: condor.src 0:7.0.2-1.fc9
Dependency Installed: classads.i386 0:1.0-1.fc9 classads-devel.i386 0:1.0-1.fc9
gsoap.i386 0:2.7.10-4.fc9 gsoap-devel.i386 0:2.7.10-4.fc9 pcre-devel.i386
0:7.3-3.fc9 postgresql.i386 0:8.3.3-1.fc9 postgresql-devel.i386 0:8.3.3-1.fc9
postgresql-libs.i386 0:8.3.3-1.fc9 tcsh.i386 0:6.15-4.fc9
Complete!
[root@dell-pe2900-03 ~]# rpmbuild -ba /usr/src/redhat/SPECS/condor.spec
error: failed to stat /usr/src/redhat/SPECS/condor.spec: No such file or directory
[root@dell-pe2900-03 ~]# ls -alh /usr/src/redhat/SPECS/
total 8.0K
drwxr-xr-x 2 root root 4.0K 2008-04-18 12:52 .
drwxr-xr-x 7 root root 4.0K 2008-06-13 10:56 ..
[root@dell-pe2900-03 ~]# rpm -q condor
condor-7.0.2-1.fc9.i386
[root@dell-pe2900-03 ~]# rpm -ql condor
DetectGCC430.patch
GLibCFlag28.patch
better-analyze-everywhere.patch
condor-7.0.2-89891-RH.tar.gz
condor.spec
condor_config.generic.patch
generate-tarball.sh
[root@dell-pe2900-03 ~]# ls
anaconda-ks.cfg                  generate-tarball.sh
better-analyze-everywhere.patch  GLibCFlag28.patch
condor-7.0.2-1.fc9.src.rpm       install.log
condor-7.0.2-89891-RH.tar.gz     install.log.syslog
condor_config.generic.patch      ks-post.log
condor.spec                      yum-2.2.2-1.rhts.EL4.noarch.rpm
DetectGCC430.patch
[root@dell-pe2900-03 ~]# rpmbuild -ba condor.spec
error: File /usr/src/redhat/SOURCES/condor-7.0.2-89891-RH.tar.gz: No such file
or directory

Comment 1 Seth Vidal 2008-06-13 18:09:55 UTC
so:
1. this shouldn't have been happening
2. it appears to have been doing this for quite some time
3. it also appears to have been doing it VERY VERY VERY WRONG for quite some time.

I'll be committing a patch shortly to more-or-less make this raise an error if
attempted.

Thank you for pointing this out.

Comment 2 Seth Vidal 2008-06-13 20:56:12 UTC
committed a fix upstream for this. Thanks


Note You need to log in before you can comment on or make changes to this bug.