Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451227 - krec hangs at startup
Summary: krec hangs at startup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 14:27 UTC by Juha Tuomala
Modified: 2008-06-24 08:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-24 08:03:27 UTC


Attachments (Terms of Use)

Description Juha Tuomala 2008-06-13 14:27:48 UTC
Description of problem:

I try to start krec and it hangs.

Version-Release number of selected component (if applicable):


How reproducible:

always

Actual results:
uname({sys="Linux", node="wasa", ...}) = 0
open("/dev/urandom", O_RDONLY)          = 14
read(14, "E[\335\33\253\342B\f\2105\270T\253\244\223k", 16) = 16
close(14)                               = 0
open("/tmp/ksocket-tuju/secret-cookie", O_WRONLY|O_CREAT|O_EXCL, 0600) = -1 
EEXIST (File exists)
open("/tmp/ksocket-tuju/secret-cookie", O_RDONLY) = 14
read(14, "cac0466788182608baf13ab50a4af024", 8192) = 32
close(14)                               = 0
ioctl(5, FIONREAD, [1])                 = 0
ioctl(5, FIONREAD, [1])                 = 0
open("/tmp/ksocket-tuju/Arts_SoundServerV2", O_RDONLY) = 14
read(14, "MCOP-Object:0000001d776173612e6e"..., 8192) = 206
close(14)                               = 0
socket(PF_FILE, SOCK_STREAM, 0)         = 14
setsockopt(14, SOL_SOCKET, SO_LINGER, {onoff=1, linger=100}, 8) = 0
connect(14, {sa_family=AF_FILE, path="/tmp/ksocket-tuju/wasa-0c4e-4833575e"}, 
110

and then nothing.

Comment 1 Rex Dieter 2008-06-13 14:40:47 UTC
Didn't you also report on irc that artscontrol hangs?  If so, you seem to have
bigger issues.

Comment 2 Juha Tuomala 2008-06-13 14:50:35 UTC
Yes, it seem to hang too.

That doesn't really change the fact that kde audio is broken on f8.

Should i file an own bug for artscontrol also?

Comment 3 Rex Dieter 2008-06-13 14:55:18 UTC
No, but I'm pretty sure what you're seeing is particular to your box, and that
these issues are related. :)

Comment 4 Juha Tuomala 2008-06-13 15:49:50 UTC
Want to make a bet? I install a fresh f8 and I quarantee that its audio is 
broken. :)

Only thing that i've done, is removed the pulseaudio-kde bridge pkg and 
wouldn't have done that if it wouldn't have been broken out-of-the-box.

Otherwise this box is intact.

Comment 5 Rex Dieter 2008-06-13 15:58:08 UTC
Sure, I've got ~150 boxes at my site that work just fine. :)

Comment 6 Rex Dieter 2008-06-13 15:58:46 UTC
oh, and you need to remove both
kde-settings-pulseaudio
and
alsa-plugins-pulseaudio

Comment 7 Juha Tuomala 2008-06-24 08:03:27 UTC
this was just screwed up system runtime situation. For some reason I'd 
lost some processes (ntp among them) and that killed sound too. 

thanks for your attention.


Note You need to log in before you can comment on or make changes to this bug.