Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451225 - broken dependencies
Summary: broken dependencies
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 14:21 UTC by Juha Tuomala
Modified: 2008-11-06 04:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-06 04:04:59 UTC


Attachments (Terms of Use)

Description Juha Tuomala 2008-06-13 14:21:27 UTC
Description of problem:

The following has been done with yum:

$ rpm -qa --qf="%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" |grep snmp
net-snmp-utils-5.4.1-7.fc8.x86_64
net-snmp-libs-5.4.1-6.fc8.x86_64
net-snmp-5.4.1-6.fc8.x86_64

Expected results:

same versions.

Comment 1 Jan Safranek 2008-06-23 13:28:04 UTC
I can't reproduce it with yum. It always updates all net-snmp-* packages, unless
I tell it to update net-snmp-utils package only - and then I get what I want,
updated net-snmp-utils and nothing else. I do not see anything wrong here.

Do you use any unusual setup, like 3rd party repos, which provide net-snmp
packages? Or how did you manage to install/update net-snmp-utils-5.4.1-7?

Comment 2 Juha Tuomala 2008-06-23 13:51:06 UTC
no, if I just try to update net-snmp-libs, I'd expect it to update everything 
that depends/links against it - and vice versa.

why would you like to get mixed versions configuration as there are no 
qurantees that it would work?

Comment 3 Jan Safranek 2008-06-23 14:09:32 UTC
(In reply to comment #2)
> why would you like to get mixed versions configuration as there are no 
> qurantees that it would work?

It's guaranteed by library soname. If an update of net-snmp-libs would break
dynamic linking, I am quite sure the updated libraries would have different
soname and all dependencies would get updated by yum. But if the ABI does not
change, there is no need to update everything, if you explicitly ask to update
just one package. You just get what you ask for - one package updated.

Using your argumentation, if e.g. glibc gets updated, would you expect to update
whole system to last version? 

You should use "yum update", without additional arguments, to update everything.



Comment 4 Juha Tuomala 2008-06-23 14:46:49 UTC
yep, that makes sense.

Comment 5 Jan Safranek 2008-11-03 08:45:12 UTC
I reconsidered the bug - in some cases (e.g. security updates) it would be better to update all net-snmp subpackages, not only the one explicitly required. There can be changes which are not reflected by soname bump.

Comment 6 Fedora Update System 2008-11-03 09:33:14 UTC
net-snmp-5.4.1-8.fc8 has been submitted as an update for Fedora 8.
http://admin.fedoraproject.org/updates/net-snmp-5.4.1-8.fc8

Comment 7 Fedora Update System 2008-11-06 04:04:56 UTC
net-snmp-5.4.1-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.