Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451209 - Text in alliance menus is missing - shows dotted rectangles instead
Summary: Text in alliance menus is missing - shows dotted rectangles instead
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: alliance
Version: 9
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Chitlesh GOORAH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 12:40 UTC by Tim Wegener
Modified: 2009-03-09 17:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-09 17:38:53 UTC


Attachments (Terms of Use)
screenshot of graal layout editor showing bad character issue (deleted)
2008-06-14 06:16 UTC, Tim Wegener
no flags Details
screenshot og graal layout editor without font problem (deleted)
2008-06-14 09:42 UTC, Thibault North
no flags Details
diff of installed package names for f8 (<) and f9 (>) (deleted)
2008-06-18 16:26 UTC, Tim Wegener
no flags Details
output of 'rpm -qa|sort' on Fedora 9 system on which problem occurs (deleted)
2008-06-25 14:30 UTC, Tim Wegener
no flags Details
output of 'rpm -qa|sort' on Fedora 8 system on which the application works fine (deleted)
2008-06-25 14:30 UTC, Tim Wegener
no flags Details

Description Tim Wegener 2008-06-13 12:40:19 UTC
Description of problem:
In the layout editor, viewer or schmetatic editor from alliance, the text in the
menus is missing. Instead, dotted rectangles appear where characters should be. 

Version-Release number of selected component (if applicable):
alliance-5.0-16.20070718snap.fc9.i386

How reproducible:
always

Steps to Reproduce:
1. Run Applications->Electronics->Alliance: Layout Editor
2. Look at the menubar and drop down menus. 
3. Notice the weird text.
  
Actual results:
Weird text (dotted rectangles instead of English characters). 

Expected results:
English words used menu items, shown correctly.

Additional info:
This is running under gnome.

Comment 1 Thibault North 2008-06-13 16:13:19 UTC
Works for me under gnome with the same alliance version. The fonts are a bit
ugly, but no rectangles here.

What about other Tk apps ?

Comment 2 Tim Wegener 2008-06-13 16:50:02 UTC
Other Tk apps are fine. e.g. magic or /usr/share/tk8.5/demos/rmt. 

Could it be due to locale issues?

$ echo $LANG
en_AU.utf8

Comment 3 Chitlesh GOORAH 2008-06-13 21:49:11 UTC
Mind to show me a screenshot, BOTH of you. I'll try to reproduce it under the 
en_AU locale this weekend.

Comment 4 Tim Wegener 2008-06-14 06:16:16 UTC
Created attachment 309326 [details]
screenshot of graal layout editor showing bad character issue

Comment 5 Thibault North 2008-06-14 09:42:37 UTC
Created attachment 309334 [details]
screenshot og graal layout editor without font problem

Comment 6 Chitlesh GOORAH 2008-06-16 17:47:57 UTC
I've tested on a freshly installed f9 with the en_AU locale. No issue at all.

Would you mind create a new user and try under that user please ?

Comment 7 Tim Wegener 2008-06-17 14:23:49 UTC
FWIW, it works for me in Fedora 8. Perhaps this is a missing fonts package
dependency issue?

Comment 8 Chitlesh GOORAH 2008-06-17 15:16:57 UTC
hmm
can you perform a

rpm -qa | sort > rpmlist_fX

where X is 8 or 9
on both machine please.

then upload the 2 files rpmlist_f8 and rpmlist_f9 here.

Comment 9 Tim Wegener 2008-06-18 16:26:01 UTC
Created attachment 309756 [details]
diff of installed package names for f8 (<) and f9 (>)

I couldn't find any obvious relevant differences.

Comment 10 Tim Wegener 2008-06-18 16:26:29 UTC
BTW, creating a new user and running from that account did not help.

Comment 11 Chitlesh GOORAH 2008-06-23 21:28:36 UTC
(In reply to comment #9)
> Created an attachment (id=309756) [edit]
> diff of installed package names for f8 (<) and f9 (>)
> 
> I couldn't find any obvious relevant differences.

Please send me the 2 files separately (not as diff) as described in comment #8.
I'm curious to know the versions as well of your installed rpms.

Comment 12 Tim Wegener 2008-06-25 14:30:01 UTC
Created attachment 310268 [details]
output of 'rpm -qa|sort' on Fedora 9 system on which problem occurs

Comment 13 Tim Wegener 2008-06-25 14:30:52 UTC
Created attachment 310270 [details]
output of 'rpm -qa|sort' on Fedora 8 system on which the application works fine

Comment 14 Aanjhan Ranganathan 2008-08-12 14:40:06 UTC
It (alliance 5.0 -16) works absolutely fine for me. No rectangular boxes and the grid also display very evenly. Am unable t reproduce this issue. 

@ Tim,
Recently the lesstif libs have been updated, can you please try again and let us know whether this is still reproducible with the updated lesstif libs? Thanks in Advance and for the support extended until now.

Comment 15 Tim Wegener 2008-08-13 00:53:52 UTC
(In reply to comment #14)
> @ Tim,
> Recently the lesstif libs have been updated, can you please try again and let
> us know whether this is still reproducible with the updated lesstif libs?

I updated lesstif then tried graal again, but the same problem occurs.

Comment 16 Chitlesh GOORAH 2008-08-13 06:38:39 UTC
This weekend, I got rex dieter try alliance. He is experiencing this issue as well on a x86_64 (on F9).

Tim can you confirm that you are using i386 arch? Maybe its not an arch dependent issue.

Comment 17 Rex Dieter 2008-11-10 17:34:38 UTC
I'm on f10/x86_64 atm.

Comment 18 Tim Wegener 2009-01-03 02:13:51 UTC
I am using i386. It still has the same problem on Fedora 10.

Comment 19 Chitlesh GOORAH 2009-01-03 14:38:02 UTC
I'm experiencing this issue as well on:
-i386
-radeon opensource driver.

Comment 20 Chitlesh GOORAH 2009-01-05 22:34:41 UTC
I have solved my bug locally without any idea how:

I did:

yum install xorg-x11-fonts*

then launch xsch

then remove all xorg-x11-fonts*


xsch (alliance-5.0-23.20070718snap.fc10.i386)

I have no dotted rectangles.

how can one explain that ?

Comment 21 Chitlesh GOORAH 2009-03-07 10:13:14 UTC
I'm no longer having this issue. Is it still an issue for you?

Comment 22 Rex Dieter 2009-03-07 13:25:46 UTC
I no longer see this either (f10/x86_64)

Comment 23 Tim Wegener 2009-03-09 03:04:52 UTC
It's working properly for me now. I'm not sure why. Maybe installing some other package installed a necessary package as a dependency.

FYI
$ rpm -qa 'xorg-x11-fonts*'
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
xorg-x11-fonts-misc-7.2-6.fc9.noarch
xorg-x11-fonts-75dpi-7.2-6.fc9.noarch


Note You need to log in before you can comment on or make changes to this bug.