Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451183 - Firefox switches to [x] Work offline on PPP/modem connection
Summary: Firefox switches to [x] Work offline on PPP/modem connection
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 09:11 UTC by Miroslav Pragl
Modified: 2018-04-11 14:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-13 22:09:12 UTC


Attachments (Terms of Use)

Description Miroslav Pragl 2008-06-13 09:11:21 UTC
Description of problem:
I use PPP/modem connection to the Internet. The connection is created (and
dialed) using system-config-network. Mozilla ignores the ppp connection and
starts with [x] Work offline mode

Version-Release number of selected component (if applicable):
firefox-3.0-0.60.beta5.fc9.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2008-06-13 16:18:49 UTC
DO you have NetworkManager running?

Comment 2 Miroslav Pragl 2008-06-13 17:45:22 UTC
Yes. I use it for controlling WLAN connections.

Unfortunately NM CAN'T control ppp connections like it could in previous 
version (I've reported this lost feature before)

MP

Comment 3 Matěj Cepl 2008-06-13 21:09:28 UTC
Do you switch off NetworkManager whenever you use PPP connection? It may signal
that it is offline to Firefox, because it is not used.

Anyway, blaming NetworkManager for this.

Comment 4 Dan Williams 2008-06-13 22:09:12 UTC
NM doesn't yet support POTS dialup yet; PPP is only implemented for PPPoE and
mobile broadband.  POTS dialup is in the works.

But, if your primary internet connection is _not_ able to be driven by
NetworkManager (like the reporter's) then the best thing to do is turn NM off with:

/sbin/chkconfig NetworkManager off

and use system-config-network to configure your networking for now.

Comment 5 Miroslav Pragl 2008-06-15 17:51:54 UTC
Hmm... I use PPP and WLAN (cca 1:1) so switching NM back and forth is same pain 
in my mouse as switching FF from offline mode.

Also it's not true that NM doesn't support dialup yet. It DID include it some 
year before, then it went away completeky, now it includes suppport for mobile 
broadband whatever gizmos.... i'd call it teenage state of SW :/

MP


Note You need to log in before you can comment on or make changes to this bug.