Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451180 - No display backlight when resuming eeepc from sleep
Summary: No display backlight when resuming eeepc from sleep
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils
Version: 9
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: FedoraMini, Mobility
TreeView+ depends on / blocked
Reported: 2008-06-13 08:39 UTC by Carlo Raudino
Modified: 2015-03-05 01:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-06-14 10:49:23 UTC

Attachments (Terms of Use)

Description Carlo Raudino 2008-06-13 08:39:15 UTC
Description of problem: Resuming eeePC 701 from sleep, results in no
backlight... for getting light back, you need to press FN+F4 (backlight
controls) and brightness come back

Version-Release number of selected component (if applicable):
fedora 9 full updated

Actual results:
We got it working, with this workaround:

This works for the eeepc701. But doesn't work in eeepc901. In this last one, the
user must HARD RESET.... no way to resume backlight.

Expected results:
Display brightness resuming, without tweaks

Comment 1 Richard Hughes 2008-06-13 10:01:34 UTC
Have you tried "pm-suspend --quirk-reset-brightness" ?

Comment 2 Carlo Raudino 2008-06-13 10:15:34 UTC
Tried now in my eeepc 701:

using pm-suspend --quirk-reset-brightness

at resume I have brightness at 125 % (it's brighter than usual maximum) , and I
can't change the brightness using Fn keys (they usually work directly, also
while loading OS)

cat /sys/devices/platform/eeepc/brn

(wrong value...)

It would be nice to test this command in eeepc 900/901, that can't resume with
the lamer workaround (reading value and setting it)

Any idea?

Comment 3 Richard Hughes 2008-06-13 11:19:14 UTC
>cat /sys/devices/platform/eeepc/brn

Why isn't the kernel using a standard brightness class?

Does xbacklight also change the brightness on this PC?

Comment 4 Carlo Raudino 2008-06-13 12:00:06 UTC
how to try it? can you tell what to do, to test it out?

ps gnome-power-management seems to not see the "brightness"..... I remember with
other distributions, it was able to change brightness...for example, with pc

Comment 5 Bastien Nocera 2008-06-13 18:30:09 UTC
xbacklight isn't shipped by default, it's available here:

This uses the driver to set the brightness, and not any kernel bits. Try
it out in X, and see if it allows the brightness to change again after a resume.

Comment 6 Carlo Raudino 2008-06-13 19:00:23 UTC
I disabled my workaround (so, stock 99video)

suspended using: pm-suspend --quirk-reset-brightness

Resumed (brightness 125 %....)

xbacklight, gives me  "100%" value

I setted with xbacklight, 50 %..... no change.... but xbacklight reports 50 %..

strange... it's like a "broken" link between hardware and software....

Comment 7 Carlo Raudino 2008-06-13 19:07:45 UTC
Now (rebooted) I tried:

stock 99video script
NORMAL SUSPEND (without --quirk-reset-brightness)

after resume (black screen....resumed pressinf Fn+F4)

xbacklight: 100 %

xbacklight -set 50 ........worked faded to 50 % brightness.

so: with stock fedora, and pressing fn+f4 , xbacklight WORKS.
using quirk-reset-brightness, xbacklight doesn't work.

Comment 8 Carlo Raudino 2008-06-14 10:49:23 UTC
GREAT, kernel-2.6.26-0.67.rc6.git1  FIXES THIS PROBLEM!

I tried, and backlight is correctly resumed.

After, I tried the "stable" kernel, and backlight doesn't work (obviously) with
it. So kernel 2.6.26 has a working resume from suspend for brightness.

Let's wait this kernel, it takes fresh air to my netbook :)

Note You need to log in before you can comment on or make changes to this bug.