Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451175 - System time is not restored after reboot
Summary: System time is not restored after reboot
Keywords:
Status: CLOSED DUPLICATE of bug 447019
Alias: None
Product: Fedora
Classification: Fedora
Component: udev
Version: 9
Hardware: i386
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 447019
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 08:09 UTC by Artem S. Tashkinov
Modified: 2008-10-11 22:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-11 22:31:31 UTC


Attachments (Terms of Use)
My kernel configuration (deleted)
2008-06-13 08:09 UTC, Artem S. Tashkinov
no flags Details

Description Artem S. Tashkinov 2008-06-13 08:09:14 UTC
Description of problem: After reboot or power off/on cycle my time is always 6
hours ahead of what is in the BIOS.

Version-Release number of selected component (if applicable): vanilla kernel
2.6.25.6, udev-120-5.20080421git.fc9.i386

How reproducible: always

Steps to Reproduce:
1. reboot or power off/on
  
Actual results: observe the system time to be six hours ahead of the real
present time

Expected results: the system date/time in sync with the HW date/time

Additional info: On Fedora 8 everything worked fine. 

cat /etc/sysconfig/clock
ZONE="Asia/Yekaterinburg"
UTC=false
ARC=false

md5sum /etc/localtime (which is Asia/Yekaterinburg)
ea4a51f79de73205bfbc875f32a3d2ce  /etc/localtime

cat /etc/adjtime (BIOS (battery) works just fine)
0.000000 1213342634 0.000000
1213342634
LOCAL

I have created this script to sync the time (not to alter system init scripts):

cat /etc/sysconfig/modules/time.modules

#! /bin/sh

echo
echo "Current  time: `date`"
echo "HW clock time: `/sbin/hwclock`"
/sbin/hwclock --hctosys
echo "Current  time: `date`"
echo "HW clock time: `/sbin/hwclock`"

as this script starts _after_ udev, I can clearly see that udev does _not_
restore the time. File /dev/rtc is present.

ls -l /dev/rtc
crw-r--r-- 1 root root 10, 135 2008-06-13 19:38 /dev/rtc

cat /proc/driver/rtc
rtc_time        : 14:03:43
rtc_date        : 2008-06-13
rtc_epoch       : 1900
alarm           : 00:00:00
DST_enable      : no
BCD             : yes
24hr            : yes
square_wave     : no
alarm_IRQ       : no
update_IRQ      : no
periodic_IRQ    : no
periodic_freq   : 1024
batt_status     : okay

I will attach my kernel configuration (note that in Fedora 1-8 everything worked
smoothly).

Comment 1 Artem S. Tashkinov 2008-06-13 08:09:14 UTC
Created attachment 309181 [details]
My kernel configuration

Comment 2 Artem S. Tashkinov 2008-10-11 22:31:31 UTC
initscripts-8.76.3-1 solved this problem for me.

*** This bug has been marked as a duplicate of bug 447019 ***


Note You need to log in before you can comment on or make changes to this bug.