Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451173 - yum update hangs every time
Summary: yum update hangs every time
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 08:01 UTC by Allan Engelhardt
Modified: 2014-01-21 23:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-16 18:33:19 UTC


Attachments (Terms of Use)
Updated packages (deleted)
2008-06-13 08:01 UTC, Allan Engelhardt
no flags Details

Description Allan Engelhardt 2008-06-13 08:01:37 UTC
Description of problem:

yum update hangs and the only way to end the process is by 
# kill -9 $(cat /var/run/yum.pid)

Version-Release number of selected component (if applicable):
yum-3.2.16-2.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1. 
# yum --verbose --noplugins update
Config time: 0.148
Yum Version: 3.2.16
COMMAND: yum --verbose --noplugins update 
Installroot: /
Reading Local RPMDB
rpmdb time: 0.000
Setting up Package Sacks
Excluding Packages in global exclude list
Finished
pkgsack time: 0.926
Setting up Update Process

2. Wait to see that nothing more happens.
3. Try SIGINT (^C), SIGQUIT (^\), kill $(cat /var/run/yum.pid), kill -15 $(cat
/var/run/yum.pid) and similar before you fall back on kill -9 $(cat
/var/run/yum.pid)

Doing a yum clean all first makes no difference.  Network connectivity and such
are of course fine.
  
Actual results: Process hangs


Expected results: Process completes.


Additional info:
This is a new problem after I installed this week's updates and rebooted the
system.  The list of updated packages (extract from yum.log) is attached.

THis may be an underlying rpm problem, but yum shouldn't just hang with no output.

Comment 1 Allan Engelhardt 2008-06-13 08:01:37 UTC
Created attachment 309180 [details]
Updated packages

Comment 2 Allan Engelhardt 2008-06-13 21:15:28 UTC
This appears to be a bad interaction with PackageKit.  Booting to runlevel 3 and
removing the gnome-packagekit package appears to fix the problem for me.

(But I still think yum should tell me what the problem is....)


Comment 3 Allan Engelhardt 2008-06-13 21:17:41 UTC
(In reply to comment #2)
> This appears to be a bad interaction with PackageKit.  Booting to runlevel 3 and
> removing the gnome-packagekit package appears to fix the problem for me.

Said that too quickly.  I am unable to use yum under Gnome / X Windows.  Does
yum use dbus anywhere?


Comment 4 Allan Engelhardt 2008-06-13 22:00:41 UTC
After (further) erasing yum-packagekit (and the dependent package PackageKit) I
am able to use yum again in a gnome-terminal.


Comment 5 Seth Vidal 2008-06-16 18:33:19 UTC
yum doesn't use dbus but packagekit does. If you want to re-enable/install it
and file this bug under packagekit I'm sure they'd appreciate it.

otherwise I'm just going to close it.



Note You need to log in before you can comment on or make changes to this bug.