Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451170 - F-10 pv_ops xen: Add x86_64 SMP support
Summary: F-10 pv_ops xen: Add x86_64 SMP support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-xen
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Eduardo Habkost
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 460292 (view as bug list)
Depends On:
Blocks: F10_XenPvOps
TreeView+ depends on / blocked
 
Reported: 2008-06-13 07:06 UTC by Holger Schmitt
Modified: 2009-12-14 20:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-21 15:41:30 UTC


Attachments (Terms of Use)

Description Holger Schmitt 2008-06-13 07:06:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b5) Gecko/2008042803 Red Hat/3.0b5-0.beta5.6.el5 Firefox/3.0b5

Description of problem:
I try to run Fedora 9 x86_64 paravirtualized on RedHat EL 5 x86_64 on Dell 2950. CPU: Intel Quadcore, RAM: 8GB, Disk: RAID5

While installation and running Fedora detects only one CPU although more than one VCPU is set in the according xen-config file.

"cat /proc/cpuinfo" shows only one CPU in guest system.

xen-config (/etc/xen/fedora) on host system:
name = "fedora"
uuid = "02a35f2f-8f4f-c8d2-c8f5-1fea42ae0132"
maxmem = 512
memory = 512
vcpus = 4
bootloader = "/usr/bin/pygrub"
on_poweroff = "destroy"
on_reboot = "restart"
on_crash = "restart"
vfb = [ "type=vnc,vncunused=1,keymap=de" ]
disk = [ "phy:/dev/sda7,xvda,w" ]
vif = [ "mac=00:16:3e:11:f8:d3,bridge=xenbr0" ]


Fedora 8 x8_64 detects 4 CPUs with the same configuration.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Install RedHat EL 5 x86_64 as host
2. Config paravirtualized guest machine via virtual machine manager, with 4 VCPUs
3. Install Fedora 9 x86_64 from network source
4. Within installation switch to console and type in "cat /proc/cpuinfo"
or
5. Install Fedora and after that type in "cat /proc/cpuinfo"


Actual Results:
- Only 1 CPU is detected by Fedora
- The CPU settings for this guest is automatically reset to 1 CPU in "Virtual machine manager" when Fedora guest starts

- Paravirtualized Fedora 8 detects 4 CPUs as expected


Expected Results:
According to xen-config file more than one CPU has to be detected by Fedora

Additional info:

Comment 1 Mark McLoughlin 2008-07-01 07:35:57 UTC
Yep, x86_64 xen DomU doesn't currently have SMP support - see also bug #437947

Comment 2 Mark McLoughlin 2008-07-21 15:41:30 UTC
Okay, with kernel-xen-2.6.27-0.2.rc0.git6.fc10.x86_64 we have SMP support again

$> uname -r
2.6.27-0.2.rc0.git6.fc10.x86_64.xen.x86_64
$> cat /proc/cpuinfo | grep processor
processor       : 0
processor       : 1


Comment 3 Mark McLoughlin 2008-09-09 14:33:01 UTC
*** Bug 460292 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.