Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451162 - Click update component on rh bugzilla -> firefox freezes
Summary: Click update component on rh bugzilla -> firefox freezes
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 03:33 UTC by sangu
Modified: 2008-10-29 09:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-29 09:42:06 UTC


Attachments (Terms of Use)

Description sangu 2008-06-13 03:33:38 UTC
Description of problem:
$ gdb firefox "ps number"
Click update componet on rh bugzilla -> firefox freezes
nsAttrAndChildArray::GetSafeChildAt (this=0xb6cd62c, aPos=0)
    at nsAttrAndChildArray.cpp:141
141	  if (aPos < ChildCount()) {

(gdb) bt
#0  nsAttrAndChildArray::GetSafeChildAt (this=0xb6cd62c, aPos=0)
    at nsAttrAndChildArray.cpp:141
#1  0x00e877ad in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0xb6cd618, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:886
#2  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0xacefb88, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#3  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0xae35220, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#4  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0xad93a18, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#5  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0x9b88920, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#6  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
---Type <return> to continue, or q <return> to quit---
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0x9b888d0, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#7  0x00e877d4 in nsAccUtils::FindDescendantPointingToIDImpl (
    aIdWithSpaces=@0xbfe77ab4, aLookContent=0xaeb8d58, 
    aRelationAttrs=0xbfe77b58, aAttrNum=1, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:890
#8  0x00e8795f in nsAccUtils::FindDescendantPointingToID (aId=0xbfe77b88, 
    aLookContent=0xaeb8d58, aRelationAttrs=0xbfe77b58, aAttrNum=1, 
    aExcludeContent=0x0, aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:834
#9  0x00e879bd in nsAccUtils::FindDescendantPointingToID (aId=0xbfe77b88, 
    aLookContent=0xaeb8d58, aRelationAttr=0x9334798, aExcludeContent=0x0, 
    aTagType=0x9334bf4) at nsAccessibilityUtils.cpp:844
#10 0x00e9425d in nsAccessible::GetHTMLLabelContent (aForNode=0xacefb88)
    at nsAccessible.cpp:1707
#11 0x00e95cfe in nsAccessible::GetHTMLName (this=0xb7ace68, 
    aLabel=@0xbfe77dd0, aCanAggregateSubtree=0) at nsAccessible.cpp:1786
#12 0x00ea65b3 in nsHTMLSelectableAccessible::GetName (this=0xb7ace68, 
    aName=@0xbfe77dd0) at nsHTMLSelectAccessible.h:87
#13 0x00eb1c79 in getNameCB (aAtkObj=0x9789140) at nsAccessibleWrap.cpp:731
#14 0x035a2df8 in atk_object_get_name (accessible=0x9789140) at atkobject.c:572
#15 0x041dda14 in spi_atk_bridge_init_base (any=0xb6cd62c, obj=0x401, 
    app=0xbfe77f3c, role=0xbfe77f38, name=0xbfe77f34) at bridge.c:1348
---Type <return> to continue, or q <return> to quit---
#16 0x041de54e in spi_atk_bridge_init_object (any=0xbfe77fac, obj=0x401, 
    c_obj=0xbfe77fc8) at bridge.c:1370
#17 0x041de992 in spi_atk_bridge_signal_listener (signal_hint=0xbfe780bc, 
    n_param_values=3, param_values=0xbfe78188, data=0x9915600) at bridge.c:1174
#18 0x05ac8293 in signal_emit_unlocked_R (node=0x9906768, detail=1338, 
    instance=0x9789140, emission_return=0x0, instance_and_params=0xbfe78188)
    at gsignal.c:2406

Version-Release number of selected component (if applicable):
3.0-0.65.cvs20080416.fc10

How reproducible:
always

Steps to Reproduce:
1. click connect rh bugzilla number
2. click update component (for changed component)
3.
  
Actual results:


Expected results:


Additional info:
xulrunner-1.9-0.65.cvs20080416.fc10.i386

Comment 1 Martin Stransky 2008-10-29 09:42:06 UTC
I can't reproduce this bug with 1.9.0.2/3.0.2 package...please reopen if the bug is still present.


Note You need to log in before you can comment on or make changes to this bug.