Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451151 - Firefox crashes when many tabs are opened simultaneously
Summary: Firefox crashes when many tabs are opened simultaneously
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 8
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-13 00:59 UTC by Charles Rezk
Modified: 2018-04-11 17:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-14 18:44:35 UTC


Attachments (Terms of Use)
"Bug report" produced by gecko when firefox crashed (deleted)
2008-06-13 01:05 UTC, Charles Rezk
no flags Details
Backtrace from firefox -g, as requested (deleted)
2008-06-13 17:36 UTC, Charles Rezk
no flags Details

Description Charles Rezk 2008-06-13 00:59:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.14) Gecko/20080416 Fedora/2.0.0.14-1.fc8 Firefox/2.0.0.14

Description of problem:
When many (6 to 10) tabs are opened simultaneously (using the "Open All in Tabs" selection in Bookmarks), Firefox will sometimes crash while loading them (usually after a number of seconds).  Whether it does so appears to depend on the content of the pages loaded: a crash seems to be more likely if there are many embedded media links in the pages being loaded.

Version-Release number of selected component (if applicable):
firefox-2.0.0.14-1.fc8

How reproducible:
Sometimes


Steps to Reproduce:
1. Load many tabs (e.g., six or more blogs).
2. Firefox may crash before they are all done loading (or not).


Actual Results:


Expected Results:


Additional info:
Gecko produces a bug report when Firefox crashes.  The file is about 500K long (a core dump?), so I can't put it here.

Comment 1 Charles Rezk 2008-06-13 01:05:28 UTC
Created attachment 309154 [details]
"Bug report" produced by gecko when firefox crashed

Comment 2 Matěj Cepl 2008-06-13 16:20:25 UTC
Unfortunately, this backtrace is almost useless for us. Could we get an
old-fashioned backtrace created by the following method, please?

Please install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Charles Rezk 2008-06-13 17:36:23 UTC
Created attachment 309261 [details]
Backtrace from firefox -g, as requested

debuginfo-install could not find anything for esound.i386 or keyutils.i386

Comment 4 Matěj Cepl 2008-06-13 21:12:03 UTC
This looks like some kind of race condition for flash player. Which sounds bad,
because we cannot do anything about it? Do you have multiple flash-needed sites
among the ones which are being opened?

Comment 5 Charles Rezk 2008-06-14 16:16:59 UTC
I was afraid of that.  Yes, there are multiple flash sites.  

Must flash crashing cause firefox to crash?

Comment 6 Matěj Cepl 2008-06-14 18:44:35 UTC
(In reply to comment #5)
> Must flash crashing cause firefox to crash?

Unfortunately for Firefox 2, yes it does -- it is effectively part of firefox
process, so when it goes down, whole thing breaks. However, Firefox 3 (which is
in Fedora 9) uses nspluginwrapper which (among other things) wraps flash plugin
so that it is not part of the firefox process, so that when flash plugin crashes
Firefox still stands.

I am afraid there is not much we can do about it with Firefox 2. Closing as
CANTFIX (because that's our situation).


Note You need to log in before you can comment on or make changes to this bug.