Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451138 - Prevent groups from being created with empty name
Summary: Prevent groups from being created with empty name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Integration-Red Hat
Version: 1.3.9
Hardware: All
OS: All
medium
low
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard: Completed Sprint #5
Depends On:
Blocks: 451141
TreeView+ depends on / blocked
 
Reported: 2008-06-12 22:49 UTC by Mike Amburn
Modified: 2008-08-20 16:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-20 16:21:45 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-06-12 22:49:50 UTC
groups being created with no group name when there is no company name and a user
logs in via user service.

if someone creates a rhn account with no company name, and then logs into the
CSP, we create a group with no company name.

one example in qa:

select * from users where first_name like 'joong%';
select * from group_users where userid = 11197;
select * from groups where gid = 2632;
select * from customer_user_cache where username ='rockoil';
select * from customer_entitlement_cache where user_cache_id = '213';

user has no entitlements. Looking in oracle, they have no company name
(supportable).

thought: if we get a customer w/no company name, we create a company name of
"USERNAME_no_company_name"

See sub task for fixing legacy groups.

This affects IssueTracker.

Comment 1 Lee Mewshaw 2008-06-17 19:54:12 UTC
Please name groups as follows:
   None (CID:n) 
where n is the Canonical ID number for the group

Thanks
Lee

Comment 2 Lee Mewshaw 2008-06-17 20:37:03 UTC
Nathan, while you're looking at this one, I think the groups are being created
with Active=No.  Please check that as well.

Lee

Comment 3 Nathan Lugert 2008-06-19 11:44:55 UTC
Changed default group name when creating new group to be "None (CID:n)" where n
is the Canonical ID number for the group. I also set group active to true.



Comment 4 Frank Merenda 2008-07-11 19:03:53 UTC
*** Bug 455047 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.