Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451128 - Users added to an account post JBoss migration are not picking up entitlements
Summary: Users added to an account post JBoss migration are not picking up entitlements
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Customer Support Portal
Classification: Retired
Component: Integration-Red Hat
Version: 1.3.9
Hardware: All
OS: All
medium
high
Target Milestone: ---
: ---
Assignee: JBoss CSP Bug Watch List
QA Contact:
URL:
Whiteboard: Completed Sprint #5
Depends On:
Blocks: 451141
TreeView+ depends on / blocked
 
Reported: 2008-06-12 22:37 UTC by Mike Amburn
Modified: 2008-08-20 16:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-20 16:17:49 UTC
Type: ---


Attachments (Terms of Use)

Description Mike Amburn 2008-06-12 22:37:13 UTC
I've seen a possible flaw in our logic of determining entitlements for customer.
I noticed that any users added to an account after the migration are not picking
up the entitlements. For example
d.parniere@quelle.fr -> has the legacy entitlements
next.user@quelle.fr created 4/2/08 -> does not have the legacy entitlements

So, the frustration is that we've associated legacy entitlements to a specific
user, and the expectation is that the other users on the account would see those
that are enterprise entitlements. Is this the way it was designed, or are we
supposed to be picking up the legacy entitlements for all users in an org?

----

Frank
Here's a reproducer in QA, both with passwords Red Hat. Both are in the same org:
d.parniere@quelle.fr
testseconduser

I'm not sure if we've introduced a bug, but there's a chance this has been
around since the migration and would explain several entitlement issues... I'd
appreciate you're assessment. This is big.


Note You need to log in before you can comment on or make changes to this bug.