Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451076 - Horde: explicit requirement for Mail_mimeDecode is not needed
Summary: Horde: explicit requirement for Mail_mimeDecode is not needed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: horde
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nigel Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 17:21 UTC by Greg Swallow
Modified: 2008-06-29 08:51 UTC (History)
1 user (show)

Fixed In Version: horde-3.2.1-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-29 08:51:59 UTC


Attachments (Terms of Use)

Description Greg Swallow 2008-06-12 17:21:28 UTC
+++ This bug was initially created as a clone of Bug #435643 +++

Description of problem:

Pear package Mail_mimeDecode is required for Horde. See F8 bug #415221.

<snip>
*** This bug has been marked as a duplicate of 415221 ***


I believe the fix for horde requiring php-pear-Mail-mimeDecode in FC8 & FC9 has 
been accomplished by php-pear-Mail-Mime requiring "php-pear(Mail_mimeDecode)"
, so there is no need for horde to require the same thing, as it already 
requires php-pear(Mail_Mime), which will pull in both rpms in FC8/9/rawhide.  
If you remove the extra mimeDecode requirement in horde then it can be built 
for EL5 without modification, as there is not a separate Mail-mimeDecode rpm 
there, mimeDecode is part of the Mail-Mime rpm.

fix:

-Requires:	php-pear(Mail_mimeDecode)

Cheers, 

Greg

PS - need any help with making/testing horde 3.2 rpms? ...especially for 
EPEL5 :-)

Comment 1 Nigel Jones 2008-06-12 23:47:50 UTC
Thanks for the bug report, I've been working on improving the whole dependency
problem, I've what can base the start of new packages locally, but I won't have
a chance to put them online for another week or so.

I'll keep EL-5 in mind.  Changing this to ASSIGNED :)

Comment 2 Nigel Jones 2008-06-22 04:38:05 UTC
(In reply to comment #1)
> Thanks for the bug report, I've been working on improving the whole dependency
> problem, I've what can base the start of new packages locally, but I won't have
> a chance to put them online for another week or so.
> 
> I'll keep EL-5 in mind.  Changing this to ASSIGNED :)
I'm pushing horde 2.2.1 to rawhide today.

I'm going to prepare some EL-5, F-8, F-9 etc RPMs later tonight for
{epel-,f9-,f8-}testing.

Comment 3 Fedora Update System 2008-06-24 04:26:51 UTC
horde-3.2.1-1.fc8 has been submitted as an update for Fedora 8

Comment 4 Fedora Update System 2008-06-24 04:27:03 UTC
horde-3.2.1-1.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-06-25 02:53:54 UTC
horde-3.2.1-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2008-06-25 02:54:26 UTC
horde-3.2.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.