Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451072 - External ext3 drive mounted with wrong permissions
Summary: External ext3 drive mounted with wrong permissions
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-mount
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 17:11 UTC by Adam Huffman
Modified: 2013-03-06 03:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-12 17:58:40 UTC


Attachments (Terms of Use)

Description Adam Huffman 2008-06-12 17:11:25 UTC
Description of problem:
When I connect an external hard drive formatted as ext3, it is mounted but the
permissions are incorrect - my normal user cannot write to it.  This seems to be
related to the lack of a default option for ext3 filesystems in the gconf key
/system/storage/default_options

Version-Release number of selected component (if applicable):
gnome-mount-0.8-1.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Connect external drive formatted as ext3
2.
3.
  
Actual results:
Drive mounted so only root can write to it

Expected results:
Drive should be mounted so that normal users can write to it

Additional info:

Directory listing for /media

total 20
drwxr-xr-x 2 root root  4096 2008-06-12 14:54 disk
drwxr-xr-x 2 adam root 16384 1970-01-01 01:00 disk-1

disk is the ext3 hard drive, disk-1 is a vfat USB stick

Comment 1 David Zeuthen 2008-06-12 17:58:40 UTC
(In reply to comment #0)
> Description of problem:
> When I connect an external hard drive formatted as ext3, it is mounted but the
> permissions are incorrect - my normal user cannot write to it.  This seems to be
> related to the lack of a default option for ext3 filesystems in the gconf key
> /system/storage/default_options

Not a bug; there's no mount option for you to take permissions; you need to
become uid 0 and then chown the contents yourself. Future disk utilities will be
able to do this for you at fs creation time; right now it looks like this

 http://people.freedesktop.org/~david/gdu-take-ownership.png


Comment 2 Adam Huffman 2008-06-13 10:37:10 UTC
Well, I would say it is a bug in the sense that gnome-mount lacks a capability
it should have - to the user concerned it was somewhat disconcerting that
automounting of a drive worked with vfat but not with ext3.  Will the future
solution propose work for already created filesystems?  If not, is there another
workaround e.g. for users who don't have root access on their machines?


Note You need to log in before you can comment on or make changes to this bug.