Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451034 - Ananconda fails when probing my video card
Summary: Ananconda fails when probing my video card
Keywords:
Status: CLOSED DUPLICATE of bug 442457
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 14:50 UTC by Vincent Alloy
Modified: 2008-06-12 14:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-12 14:53:35 UTC


Attachments (Terms of Use)
Traceback of anaconda after the bug (deleted)
2008-06-12 14:50 UTC, Vincent Alloy
no flags Details

Description Vincent Alloy 2008-06-12 14:50:31 UTC
Description of problem:
Installation or upgrade fails on Dell Optiplex 745 equipped with Intel
Corporation 82Q963/Q965 Integrated Graphics Controller

Version-Release number of selected component (if applicable):
Fedora Core 9

How reproducible:
Just try to install Fedora Core 9 or upgrade from FC8 to FC9 on a Dell Optiplex 745.


Steps to Reproduce:
1. Start the installation/upgrade procedure.
2. 
3.
  
Actual results:
Running anaconda 11.4.0.82, the Fedora system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 877, in <module>
    probeHW(opts, x_already_set, xserver)
  File "/usr/bin/anaconda", line 456, in probeHW
    xserver.probeHW(forceDriver=opts.xdriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/xserver.py", line 84, in probeHW
    self.videohw = videocard.VideoCardInfo(forceDriver=forceDriver)
  File "/usr/lib64/python2.5/site-packages/rhpxl/videocard.py", line 135, in
__init__
    devs = [bus.get_object('org.freedesktop.Hal', x) for x in devs]
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 237, in __init__
    _dbus_bindings.validate_object_path(object_path)
ValueError: Invalid object path
'/org/freedesktop/Hal/devices/storage_model_SAMSUNG_HD080HJ/': ends with '/' and
is not just '/'
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc done
        /dev/pts done
        /sys done
        /mnt/source done
        /selinux done
you may safely reboot your system

Expected results:
Go to the following step :)

Additional info:
According to the traceback, it seems that anaconda was trying to probe my video
card but failed. Another element is the line about my Samsung harddrive. Don't
know who is the culprit.

Comment 1 Vincent Alloy 2008-06-12 14:50:31 UTC
Created attachment 309074 [details]
Traceback of anaconda after the bug

Comment 2 Chris Lumens 2008-06-12 14:53:35 UTC

*** This bug has been marked as a duplicate of 442457 ***


Note You need to log in before you can comment on or make changes to this bug.