Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451020 - kickstart install ignores repo option
Summary: kickstart install ignores repo option
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 13:30 UTC by Jari Takkala
Modified: 2008-09-08 18:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-08 18:02:37 UTC


Attachments (Terms of Use)

Description Jari Takkala 2008-06-12 13:30:36 UTC
Description of problem:
If I specify additional repo's in my kickstart config file, the installer does
not appear to create these additional repos in /etc/yum.repos.d/. The installer
also does not include the repo options in /root/anaconda-ks.cfg after the
install completes.

How reproducible:
Create a kickstart script with a repo option, and perform a kickstart install.

Steps to Reproduce:
1. Create kickstart script with a custom repo option.
2. Do a kickstart install using the script.
3. Check /etc/yum.repos.d/ directory.
  
Actual results:
/etc/yum.repos.d/ does not contain the new repository.

Expected results:
/etc/yum.repos.d/ should contain a file with the repository configuration
specified in the kickstart script.

Additional info:
See
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Installation_Guide/s1-kickstart2-options.html#id2950303
for info on this config option.

Comment 1 Chris Lumens 2008-06-16 13:20:02 UTC
We're not writing them out in /etc/yum.repos.d on purpose.  I no longer remember
the precise reasoning for this, but I remember there definitely was a reason. 
We should probably investigate this for F10 so it has a chance of being fixed in
RHEL6.

As far as not including them in the anaconda-ks.cfg file, future versions of
RHEL will simply copy the input kickstart file to the output, so whatever you
specified will get preserved.

Comment 2 Chris Lumens 2008-06-21 21:08:15 UTC
Moving this to Fedora since we're unlikely to ever get this into a RHEL update
release and that's the proper place to fix it anyway.

Comment 3 Orion Poplawski 2008-07-17 16:17:00 UTC
For me it seems to add the last one:

url --url=http://<fedora>
repo --name=<first>
repo --name=<second>

The installer uses the second repository but not the first and I get missing
package errors.

Comment 4 Chris Lumens 2008-08-29 20:35:02 UTC
Gah, yes I'm seeing the same thing caused by a really stupid typo.  This will be fixed in the next build of anaconda.

Comment 5 Orion Poplawski 2008-09-08 16:00:36 UTC
Still a problem.

Repo ks config:

url --url=http://fedora.cora.nwra.com/fedora/linux/development/i386/os
vnc
repo --name=CoRA --baseurl=http://sw.cora.nwra.com/fedora/CoRPMS/fcdevelopment/i386/
repo --name=livna --baseurl=http://livna.cora.nwra.com/development/i386/
repo --name=adobe-linux --baseurl=http://adobe.cora.nwra.com/linux/i386/

anaconda.log repo info:

09:52:30 INFO    : anaconda called with cmdline = ['/usr/bin/anaconda', '--stage2', 'http://fedora.cora.nwra.com/fedora/linux/development/i386/os/images/stage2.img', '--noipv6', '--kickstart', '/tmp/ks.cfg', '-T', '--selinux', '--lang', 'en_US.UTF-8', '--keymap', 'us', '--repo', 'http://fedora.cora.nwra.com/fedora/linux/development/i386/os']


09:53:27 INFO    : moving (1) to step reposetup
09:53:28 INFO    : added repository adobe-linux with URL ['http://adobe.cora.nwra.com/linux/i386/']
09:53:28 WARNING : ignoring duplicate repository adobe-linux with URL ['http://adobe.cora.nwra.com/linux/i386/']
09:53:28 WARNING : ignoring duplicate repository adobe-linux with URL ['http://adobe.cora.nwra.com/linux/i386/']
09:53:36 WARNING : /usr/lib/python2.5/site-packages/yum/repos.py:64: RuntimeWarning: YumProgress.progressbar called when popped
  self.callback.progressbar(num, len(repos), repo.id)

Comment 6 Chris Lumens 2008-09-08 16:49:56 UTC
What version of anaconda are you using?

Comment 7 Orion Poplawski 2008-09-08 16:53:30 UTC
I'm using 11.4.1.32.

Comment 8 Chris Lumens 2008-09-08 17:26:19 UTC
Hm, I'm definitely not seeing this with today's rawhide.

Comment 9 Orion Poplawski 2008-09-08 17:58:23 UTC
Sorry, my mirror copy was not working properly.

I'm getting cannot find stage2.img errors now (they seem to be missing), but that's another issue.

Comment 10 Chris Lumens 2008-09-08 18:02:37 UTC
Yeah, file that as a separate bug please.


Note You need to log in before you can comment on or make changes to this bug.