Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451006 - programs build with gcc 4.3 based on gsl require -fgnu89-inline
Summary: programs build with gcc 4.3 based on gsl require -fgnu89-inline
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gsl
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 11:28 UTC by Matěj Cepl
Modified: 2018-04-11 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-28 01:37:03 UTC


Attachments (Terms of Use)

Description Matěj Cepl 2008-06-12 11:28:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5) Gecko/2008043010 Fedora/3.0-0.60.beta5.fc9 Firefox/3.0b5

Description of problem:
For the further description see discussion on this thread
http://thread.gmane.org/gmane.comp.statistics.pspp.devel/1898/focus=1908

Version-Release number of selected component (if applicable):
gcc-4.3.0-8.i386, gsl-devel-1.10-10.fc9.i386, pspp-0.6.0-2.fc9.i386, gsl-1.10-10.fc9.i386, gcc-c++-4.3.0-8.i386

How reproducible:
Always


Steps to Reproduce:
1.Build the src.rpm

Actual Results:
Build fails unless
CFLAGS="${CFLAGS:-%optflags} -fgnu89-inline"
is added as a parameter of %configure

Expected Results:
Shouldn't fail

Additional info:

Comment 1 Matěj Cepl 2008-06-12 11:50:03 UTC
Package which fails when build is
http://mcepl.fedorapeople.org/rpms/pspp-0.6.0-2.0.tofail.fc9.src.rpm
and with the above shown %configure line it built perfectly in koji
http://koji.fedoraproject.org/koji/taskinfo?taskID=658938

Comment 2 Ivana Varekova 2008-06-18 07:08:42 UTC
Fixed in gsl-1.11-2.fc10.

Comment 5 Milos Jakubicek 2009-02-03 19:40:36 UTC
Why the related patch has been removed and replaced by the -fgnu89-inline flag?

Note that this probably solves the problem for building gsl, but definitely not for other packages which link to it -- they fail to build again.

I just wondered why one of my packages (orsa) failed to build [1] in the mass gcc 4.4 rebuild and was in the category "fails-even-with-43" although I was able to build it with gcc 4.3 in the summer.

Please put that patch back and try to move it upstream.

[1] http://sunsite.mff.cuni.cz/rawhide20090126-gcc44/fails-even-with-43/orsa-0.7.0-2.fc10.src.rpm/build.log

Comment 6 Milos Jakubicek 2009-02-28 01:37:03 UTC
Taking back, sorry, this was caused by wrong propagation of the HAVE_INLINE macro in orsa. Nevertheless looking into gsl/gsl_inline.h, I think that the "-fgnu89-inline flag" could be removed at all -- this should be now (and it indeed seems to be) completely covered by the INLINE_FUN macro which is either set to "extern inline" (for the old gnu C) or just to "inline" (for c99).


Note You need to log in before you can comment on or make changes to this bug.