Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 451004 - mockbuild of i386 packages on x86_64 platform lacks pg_config_i386.h
Summary: mockbuild of i386 packages on x86_64 platform lacks pg_config_i386.h
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 10:54 UTC by Ingvar Hagelund
Modified: 2013-07-03 03:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-17 04:23:03 UTC


Attachments (Terms of Use)

Description Ingvar Hagelund 2008-06-12 10:54:08 UTC
Description of problem:
When building i386 packages from source rpm with mock on x86_64 machine,
postgresql-devel lacks /usr/include/pg_config_i386.h and
/usr/include/pgsql/server/pg_config_i386.h

Version-Release number of selected component (if applicable):
any recent fedora postgresql package

Note that I tested this with mock-0.6 on an ubuntu system. A control build with
a fedora stamped mock should be done to make sure the issue is present on fedora
as well. I'll try to do this when I get home and get time and find a decent machine.

How reproducible:
Always

Steps to Reproduce:
1. Do an i386 mockbuild of postgresql on a x86_64 machine
2. rpm -qpl postgresql-devel*.rpm | grep pg_config_i386.h

  
Actual results:
no output

Expected results:
/usr/include/pg_config_i386.h
/usr/include/pgsql/server/pg_config_i386.h


Additional info:
Workaround: run mock with linux32 wrapper

The postgresql build should not use uname -{i,p,m} when deciding what files to
create, but rely on %{ARCH} from rpmbuild/mock/whatever.

Comment 1 Ingvar Hagelund 2008-06-12 10:58:45 UTC
I forgot, I only have i386 on my fedora boxes at home. 

Comment 2 Tom Lane 2008-06-12 14:08:57 UTC
Why in the world does mock not provide that wrapper?  I think this is a mock bug.

Comment 3 Rajesh Krishnan 2008-06-17 02:47:38 UTC
I have an x86_64 machine running Fedora-8.  I was not able to find 
the /usr/bin/pg_config installed by the postgresql-devel RPM package, even 
though the RPM lists the entry.

Is it possible to get a fixed RPM anytime soon for Fedora-8?

-Rajesh



Comment 4 Tom Lane 2008-06-17 04:23:03 UTC
Ingvar: I tried the case just now using Fedora 8's mock, and it works as expected.  So I'm of the opinion 
that you are looking at a bug in Ubuntu's mock.  mock is supposed to reproduce the target system's build 
environment, and they're clearly missing a bet there.

Rajesh: that file is certainly present in the RPM.  You might possibly have a gripe to file against yum or 
rpm itself, but I don't think you've ruled out plain old pilot error.  In any case, please don't attach unrelated 
issues to existing bugzilla entries.

Comment 5 Tom Lane 2008-06-17 04:28:04 UTC
Oh, another data point: mock on current Fedora 8 is mock-0.9.7-2.  Maybe this is just something that got 
fixed since 0.6?

Comment 6 Ingvar Hagelund 2008-06-17 11:16:29 UTC
You're probably right. I guess I have to nag someone to upgrade that mock
package on this ubuntu system.

Thanks for your time looking into this. I'll leave the bug closed.

Ingvar



Note You need to log in before you can comment on or make changes to this bug.