Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450997 - SOS can collect gdm.conf in RHEL4 but can not collect custom.conf in RHEL5
Summary: SOS can collect gdm.conf in RHEL4 but can not collect custom.conf in RHEL5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos
Version: 5.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact:
URL:
Whiteboard:
: 472528 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 07:37 UTC by Zhenyong(Jerry) Jiang
Modified: 2013-07-29 00:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 07:29:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1418 normal SHIPPED_LIVE sos bug fix and enhancement update 2009-09-02 07:29:42 UTC

Description Zhenyong(Jerry) Jiang 2008-06-12 07:37:07 UTC
Description of problem:

The config file for GDM is /etc/X11/gdm/gdm.conf in RHEL4, but
/etc/gdm/customer.conf in RHEL5.

SOS in RHEL5 does not collect customer.conf but SOS RHEL4 can collect gdm.conf.

Version-Release number of selected component (if applicable):

How reproducible:
100%

Steps to Reproduce:
1.run sos
2.check etc/gdm/customer.conf in tarball.
  
Actual results:
No customer.conf in tarball.

Expected results:
It should be in the tarball


Additional info:

This is the sos plugin which can collect the gdm config files.
[jerry@dhcp-0-151 plugins]$ cat gdm.py
### This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
## the Free Software Foundation; either version 2 of the License, or
## (at your option) any later version.

## This program is distributed in the hope that it will be useful,
## but WITHOUT ANY WARRANTY; without even the implied warranty of
## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
## GNU General Public License for more details.

## You should have received a copy of the GNU General Public License
## along with this program; if not, write to the Free Software
## Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.

import sos.plugintools
import os

class gdm(sos.plugintools.PluginBase):
   """gdm related information
   """
   def setup(self):
       self.addCopySpec("/etc/gdm/*")
       return

Comment 3 Adam Stokes 2009-02-10 11:21:59 UTC
*** Bug 472528 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2009-09-02 07:29:59 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1418.html


Note You need to log in before you can comment on or make changes to this bug.