Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450994 - Restore from star archive does not resotre default acls.
Summary: Restore from star archive does not resotre default acls.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: star
Version: 5.1
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 05:21 UTC by Kurt Bechstein
Modified: 2018-10-20 03:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-11 09:16:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to fix the issue (deleted)
2008-12-03 11:32 UTC, Olivier Fourdan
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1575 normal SHIPPED_LIVE star bug fix update 2009-11-11 09:16:00 UTC

Description Kurt Bechstein 2008-06-12 05:21:41 UTC
Description of problem:
Under RHEL 5 I'm trying to backup some directories that I have some default acls
setup on.  According to the documentation I should use the star command rather
than tar.  After restoring from the star archive the default acls are gone, but
the access acls are present.  My guess is that its a bug in the star command in
RHEL5 since I can run the exact same commands on a Fedora 9 box and it works as
expected.


Version-Release number of selected component (if applicable):
star-1.5a75-2

How reproducible:  Every time.


Steps to Reproduce:
1.  Create a directory called testing on a filesystem mounted with acl support.
2.  getfacl testing
# file: testing
# owner: root
# group: root
user::rwx
group::r-x
other::r-x


3.Set some default acls:
  setfacl -d -m u::rx testing
  
  getfacl testing/
# file: testing
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::r-x
default:group::r-x
default:other::r-x

Default acls show up as expected.  

4.  Create star archive:
    star H=exustar -acl -c -v f=startest.star testing/
a testing/ directory
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).

5.  Remove original directory with rmdir testing
6.  Restore directory from star archive:
    star -acl -x -v f=startest.star 
Release     star 1.5a75 (i386-redhat-linux-gnu)
Archtype    exustar
Dumpdate    1213247797.030692 (Thu Jun 12 01:16:37 2008)
Volno       1
Blocksize   20
x testing/ directory
star: 1 blocks + 0 bytes (total of 10240 bytes = 10.00k).

  
Actual results:
After the above restore getfacl testing/ yields:
# file: testing
# owner: root
# group: root
user::rwx
group::r-x
other::r-x

--defaul acls missing

Expected results:
 getfacl testing/
# file: testing
# owner: root
# group: root
user::rwx
group::r-x
other::r-x
default:user::r-x
default:group::r-x
default:other::r-x

Additional info:
As I mentioned when running the exact same commands on a fedora 9 machine with
star version star-1.5a84-4.fc9.i386 this worked just as expected.

Comment 1 Kurt Bechstein 2008-09-12 18:12:44 UTC
Anything happening with this bug or can I supply some kind of other information?

Comment 2 Ondrej Vasik 2008-09-15 07:15:48 UTC
Thanks for report, no additional informations are needed at the moment, sorry for delay. As the problem is in RHEL-5, I would suggest to contact official Red Hat Enterprise Linux product support to raise priority of star update. I will try to backport fix and attach a patch if possible, but it will take some time.

Comment 3 Olivier Fourdan 2008-12-03 11:32:39 UTC
Created attachment 325521 [details]
Patch to fix the issue

Testing in-between releases shows that the problem was fixed upstream between star-1.5a78 and star-1.5a79.

The attached patch (1 line added) seems to fix the issue.

Cheers,
Olivier.

Comment 5 RHEL Product and Program Management 2009-03-26 16:49:23 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 13 errata-xmlrpc 2009-11-11 09:16:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1575.html


Note You need to log in before you can comment on or make changes to this bug.