Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450990 - virt-install ks-based guest creation errors during disk initialization part
Summary: virt-install ks-based guest creation errors during disk initialization part
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst
Version: 5.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 05:09 UTC by erik tapang
Modified: 2009-12-14 21:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-12 10:58:42 UTC


Attachments (Terms of Use)
anacdump and virt-install log (deleted)
2008-06-12 05:09 UTC, erik tapang
no flags Details
kickstart file (deleted)
2008-06-12 05:11 UTC, erik tapang
no flags Details

Description erik tapang 2008-06-12 05:09:52 UTC
Description of problem:
trying to create a guest system using virt-install. ks install start out but
during the disk init part, a prompt appers with the message:

 Operation not permitted during write on /dev/xvdb

[Retry  Ignore ...

pressed Ignore and goes to an anaconda trace window.

Version-Release number of selected component (if applicable):

python-virtinst-0.300.2-8.el5

How reproducible:
always 



Steps to Reproduce:
1. virt-install -p -n node01 -r 1000 -f /dev/Virtual00VG/lvNODE01  -m
00:16:3e:21:c5:c1 -w network:public1  --os-type=linux --os-variant=rhel5
--arch=x86_64   -l /var/ftp/pub/rhel5u2/rhel-5-server-x86_64-dvd.iso  -x
ks=http://192.168.222.1/rhel5u2/node01_ks.cfg ksdevice=eth0  --vnc --debug
2. check the vnc session a prompt appears
3. press ignore and trace dump appears and then prompts to reboot
  
Actual results:
guest creation is unsuccessful

Expected results:
disk initialization should be ok

Additional info:
anaconda trace and virt-install log (combined) attached.

Comment 1 erik tapang 2008-06-12 05:09:52 UTC
Created attachment 309026 [details]
anacdump and virt-install log

Comment 2 erik tapang 2008-06-12 05:11:34 UTC
Created attachment 309027 [details]
kickstart file

Comment 3 erik tapang 2008-06-12 07:02:39 UTC
i've recreated the LV:

lvcreate -L 30G  -n lvNODE01 Virtual00VG

and re-installed using the same virt-install syntax, and it got through the
whole process.

previously, lvNODE01 used in guest system is created using this syntax:

lvcreate -L 30G -i 2 -n lvNODE01 Virtual00VG

# Virtual00VG has 2 x 100G HP EVA8K LUN

so does my problem has something to do with the striped LV?

Comment 4 Daniel Berrange 2008-06-12 10:58:42 UTC
Your  virt-install command line only specifies a single disk (ie f
/dev/Virtual00VG/lvNODE01) which will become xvda.  Your kickstart file
specifies two disks xvda and xvdb. Since xvdb does not exit (you didn't ask
virt-install for 2 disks) it will obvious fail to install.



Note You need to log in before you can comment on or make changes to this bug.