Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450988 - nautilus -q -> Segmentation fault
Summary: nautilus -q -> Segmentation fault
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-actions
Version: rawhide
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-12 04:08 UTC by sangu
Modified: 2008-10-28 04:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-28 04:36:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 480179 None None None Never

Description sangu 2008-06-12 04:08:01 UTC
Description of problem:
[New Thread 0xb7d83b90 (LWP 3693)]
seahorse nautilus module initialized
$gdb nautilus
$r -q
[...]
Initializing nautilus-flac-converter extension
Initializing nautilus-open-terminal extension
Initializing nautilus-image-converter extension

Program received signal SIGSEGV, Segmentation fault.
0x00c333f6 in gconf_client_remove_dir (client=0x7600000c, 
    dirname=0x7f3736c "/apps/nautilus-actions/configurations", err=0x0)
    at gconf-client.c:705
705	  found = g_hash_table_lookup (client->dir_hash,

(gdb) bt
#0  0x00c333f6 in gconf_client_remove_dir (client=0x7600000c, 
    dirname=0x7f3736c "/apps/nautilus-actions/configurations", err=0x0)
    at gconf-client.c:705
#1  0x07f32cc6 in ?? ()
   from /usr/lib/nautilus/extensions-2.0/libnautilus-actions.so
#2  0x00cd5413 in IA__g_object_unref (_object=0x9168e38) at gobject.c:1793
#3  0x07f2f964 in ?? ()
   from /usr/lib/nautilus/extensions-2.0/libnautilus-actions.so
#4  0x00cd5378 in IA__g_object_unref (_object=0x9168e20) at gobject.c:1765
#5  0x08135f4d in free_module_objects () at nautilus-module.c:219
#6  0x0016111c in eel_debug_shut_down () at eel-debug.c:110
#7  0x0807ca9f in main (argc=2, argv=0xbf8465b4) at nautilus-main.c:590

$ dmesg | grep nautilus
nautilus[2699]: segfault at 97000020 ip 00c333f6 sp bfa588a0 error 4 in
libgconf-2.so.4.1.5[c12000+34000]
nautilus[3680]: segfault at 6c000020 ip 00c333f6 sp bfe11710 error 4 in
libgconf-2.so.4.1.5[c12000+34000]
nautilus[3685]: segfault at 71000020 ip 00c333f6 sp bfa30330 error 4 in
libgconf-2.so.4.1.5[c12000+34000]

Version-Release number of selected component (if applicable):
2.23.3-1.fc10

How reproducible:
always

Steps to Reproduce:
1. $ nautilus -q
2.
3.
  
Actual results:


Expected results:


Additional info:
GConf2-2.23.1-1.fc10.i386

Comment 1 sangu 2008-06-13 03:38:41 UTC
nautilus-actions-1.4.1-4.fc10.i386

http://bugzilla.gnome.org/show_bug.cgi?id=480179

Comment 2 John Poelstra 2008-10-19 02:20:41 UTC
(In reply to comment #1)
> nautilus-actions-1.4.1-4.fc10.i386
> 
> http://bugzilla.gnome.org/show_bug.cgi?id=480179

Looks the gnome bug has just been closed as fixed... Fedora needs nautilus-actions-1.4.2 now?

Comment 3 Matthias Clasen 2008-10-19 03:04:25 UTC
Don't know if we'll get a new release anytime soon. 
Might be better to go with an svn snapshot than to wait for a release.

Comment 4 Matthias Clasen 2008-10-21 05:25:36 UTC
Not a blocker anyway, since nautilus-actions is not in the default install. 
But it would still be good to fix.

Comment 5 Deji Akingunola 2008-10-23 18:20:09 UTC
I've followed Matthias suggestion and build current svn snapshot in rawhide.


Note You need to log in before you can comment on or make changes to this bug.