Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450954 - Currently reprovisioning with a new base channel (via activation key) doesnt' work
Summary: Currently reprovisioning with a new base channel (via activation key) doesnt'...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: 510
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Steve Salevan
URL:
Whiteboard:
: 449846 (view as bug list)
Depends On:
Blocks: 496145
TreeView+ depends on / blocked
 
Reported: 2008-06-11 21:14 UTC by Justin Sherrill
Modified: 2018-10-20 01:51 UTC (History)
6 users (show)

Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 496145 (view as bug list)
Environment:
Last Closed: 2009-09-10 19:22:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Justin Sherrill 2008-06-11 21:14:12 UTC
In 5.1 we modified reprovisioning to allow re-activation keys and activation
keys to work together.  

Currently though, if the activation key has a different base channel, the
registration fails with a conflicting activation key error.

We need to modify the backend so that it will look at the non-reactivation key
for the base channel if they differ.

Comment 1 Clifford Perry 2008-10-08 16:11:21 UTC
*** Bug 449846 has been marked as a duplicate of this bug. ***

Comment 2 Brandon Perkins 2008-10-08 16:12:22 UTC
Bug 449846 has been marked as a duplicate of this bug.  Please verify this to be the case.  The issue still needs to be checked, but Cliff and I found no delta between the two.

Comment 4 Justin Sherrill 2009-04-15 22:17:06 UTC
This should work now and should be fairly easily backport-able.

master:  d040ff9..8faefeb
VADER:  8ae88c8..a8c674e


The fix basically involved not setting the base channel of a reactivation token unless there is an activation token with another base channel set.

You will still get a conflicting base channel message if you have two regular activation keys with different base channels, but you should no longer receive the message if you have a single activation key with a different base channel and try to re-provision with it.

Comment 8 Steve Salevan 2009-06-05 21:55:38 UTC
VERIFIED on 5/29 build.

Comment 9 Preethi Thomas 2009-08-03 13:34:00 UTC
Release Pending
test1182.test.redhat.com
kickstarted test01-64 using rhel5u3 profile that has activation to register to clone-rhel5 channel

Comment 10 Brandon Perkins 2009-09-10 19:22:53 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html


Note You need to log in before you can comment on or make changes to this bug.