Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450944 - Holding down a keyboard key does not repeat the character when using free Windows VNC viewer
Summary: Holding down a keyboard key does not repeat the character when using free Win...
Keywords:
Status: CLOSED DUPLICATE of bug 450033
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: 9
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-11 20:38 UTC by Jim Hennessy
Modified: 2013-04-30 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-12 10:19:47 UTC


Attachments (Terms of Use)

Description Jim Hennessy 2008-06-11 20:38:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14

Description of problem:
I use the free VNC viewer from www.realvnc.com on Windows XP to access some Fedora machines.  The VNC client version is 4.1.2, the latest available but unchanged since May 2006.  If I access a Fedora 9 system using this client, keyboard repeating doesn't work.  That is, if I open, say, a konsole window and press and hold a keyboard key when focus is in this window, it does not repeat the keystroke on the konsole window.  The same effect occurs for all input fields.  For example, the URL text entry field in Firefox or a gnome-console window behaves the same.  It occurs both when using Gnome and KDE as the window manager.  I start vncserver on Fedora 9 in the normal way, as a service, with configuration info in /etc/sysconfig/vncservers.

I've tried messing with various client settings such as whether to pass special keys or using full screen mode, but I've found none that change this.

If I access a Fedora 8 system using this client, key repetition works fine.  Similarly, if I using the Fedora 8 vncviewer program to access the Fedora 9 system, key repetition works fine.

I know this test makes it sound like the bug is in the Windows VNC client, but the fact that it works for a Fedora 8 VNC server suggests that some unwanted change occurred in the Fedora 9 version of vncserver.

Version-Release number of selected component (if applicable):
vnc-server-4.1.2-30.fc9.i386

How reproducible:
Always


Steps to Reproduce:
1. Use the free VNC client from RealVNC on Windows XP to access a Fedora 9 system.
2. Open gnome-terminal or any other gui application that accepts keyboard input.
3. Press and hold a key on the keyboard.

Actual Results:
The entered character is not repeated in the text entry field.

Expected Results:
The entered character should have been repeated in the text entry field.

Additional info:
I rated this bug as having medium severity, but since my primary method of accessing my Linux machines is via VNC from Windows XP, this bug is preventing me from upgrading any of my machines to Fedora 9.

Comment 1 Adam Tkac 2008-06-12 10:19:47 UTC

*** This bug has been marked as a duplicate of 450033 ***


Note You need to log in before you can comment on or make changes to this bug.