Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450940 - [RFE] passkey-agent is missing
Summary: [RFE] passkey-agent is missing
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bluez-utils
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-11 20:16 UTC by Mats Karlsson
Modified: 2015-02-01 22:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-13 14:07:03 UTC


Attachments (Terms of Use)
Changes to bluez-utils-3.7-2.el5 (deleted)
2008-06-12 12:41 UTC, Mats Karlsson
no flags Details | Diff
Default pincode (deleted)
2008-06-12 12:42 UTC, Mats Karlsson
no flags Details

Description Mats Karlsson 2008-06-11 20:16:31 UTC
Description of problem:
In bluez-util ver. 3.x has the pairing process changed and the old way with
pinhelper is not working any more.
The new way is a component that is called passkey-agent, but the make script
just compile it but doesnt install it.
To fill the gap/need of a way to pair bluetooth devices from the cli or via a
daemon I would like to suggest that the passkey-agent and a start stop script ++
is incorporated into either the bluez-util rpm or a bluez-util-pin package.

Version-Release number of selected component (if applicable):
bluez-util ver. 3.x

How reproducible:
Make

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
In more resent releases of bluez-util is there a new daemon that should be
investigated if thats a more suitable way for newer releases

Comment 1 Mats Karlsson 2008-06-12 12:41:58 UTC
Created attachment 309063 [details]
Changes to bluez-utils-3.7-2.el5

Comment 2 Mats Karlsson 2008-06-12 12:42:47 UTC
Created attachment 309064 [details]
Default pincode

Comment 3 Bastien Nocera 2008-07-02 16:45:08 UTC
bluez-gnome (available in RHEL5) already contains a passkey agent for hcid to
use, over D-Bus. Make sure bluetooth-applet is started on your system if you
don't use GNOME as your desktop.

Comment 4 Mats Karlsson 2008-07-02 17:23:06 UTC
And since I don't have a Desktop, just a CLI how is this a fix for that ?
Im sorry that I didn't state that the RFE was to solve a console/CLI situation
since I don't have a Desktop on my servers, they just run the CLI.

Comment 5 C.Lee Taylor 2009-09-27 18:49:31 UTC
For TUI installations, this is really needed.  I would second this, hoping that a fix will be put in place.  Tested myself with a custom compile and install and I'm not able to find any other way to get BlueTooth pairing working without the passkey-agent.

Thanks
LeeT

Comment 7 Radek Vokal 2010-04-13 14:07:03 UTC
This feature should be addressed in upstream first. If you feel that this problem is critical for you, feel free to contact redhat.com/support to raise a priority of this issue.


Note You need to log in before you can comment on or make changes to this bug.