Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450919 - Dependencies conflict when trying to install
Summary: Dependencies conflict when trying to install
Keywords:
Status: CLOSED DUPLICATE of bug 444263
Alias: None
Product: Fedora
Classification: Fedora
Component: hamster-applet
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mads Villadsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-11 18:08 UTC by George Notaras
Modified: 2008-06-11 21:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-11 19:22:46 UTC


Attachments (Terms of Use)

Description George Notaras 2008-06-11 18:08:18 UTC
Description of problem:
Trying to install hamster-applet results in the following error:


# yum install hamster-applet
[...]
Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 hamster-applet          i386       0.5-1.fc9        updates           139 k
Installing for dependencies:
 GConf2-devel            i386       2.22.0-1.fc9     fedora            103 k
 ORBit2-devel            i386       2.14.12-3.fc9    fedora            187 k
 audiofile-devel         i386       1:0.2.6-8.fc9    fedora             16 k
 dbus-glib-devel         i386       0.74-8.fc9       updates            40 k
 esound-devel            i386       1:0.2.38-7.fc9   fedora             18 k
 evolution-data-server-devel  i386       2.22.1-2.fc9     fedora            276 k
 evolution-data-server-doc  i386       2.22.1-2.fc9     fedora            515 k
 gnome-python2-evolution  i386       2.22.0-2.fc9     fedora             36 k
 gnome-vfs2-devel        i386       2.22.0-1.fc9     fedora            260 k
 gnutls-devel            i386       2.0.4-3.fc9      updates           1.3 M
 libbonobo-devel         i386       2.22.0-2.fc9     fedora            509 k
 libgnome-devel          i386       2.22.0-3.fc9     fedora             84 k
 libsoup-devel           i386       2.4.1-1.fc9      fedora            158 k
 popt-devel              i386       1.13-3.fc9       fedora            395 k

Transaction Summary
=============================================================================
Install     15 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)
[...]
Transaction Check Error:
  file /usr/lib/python2.5/site-packages/gtk-2.0/evolution/__init__.pyc from
install of gnome-python2-evolution-2.22.0-2.fc9.i386 conflicts with file from
package evolution-python-0.0.4-3.fc9.i386
  file /usr/lib/python2.5/site-packages/gtk-2.0/evolution/__init__.pyo from
install of gnome-python2-evolution-2.22.0-2.fc9.i386 conflicts with file from
package evolution-python-0.0.4-3.fc9.i386
  file /usr/lib/python2.5/site-packages/gtk-2.0/evolution/ebook.so from install
of gnome-python2-evolution-2.22.0-2.fc9.i386 conflicts with file from package
evolution-python-0.0.4-3.fc9.i386
  file /usr/lib/python2.5/site-packages/gtk-2.0/evolution/ecal.so from install
of gnome-python2-evolution-2.22.0-2.fc9.i386 conflicts with file from package
evolution-python-0.0.4-3.fc9.i386

Version-Release number of selected component (if applicable):
0.5-1.fc9

How reproducible:
Always

Additional question:
Are all these development packages needed by the hamster-applet or is there a
mistake in the SPEC file?

Comment 1 Mads Villadsen 2008-06-11 19:22:46 UTC
The conflict has been fixed in gnome-python2-desktop-2.22.0-3 (see bug #444263)
and evolution-python is being removed from Fedora since it is no longer needed.

If you don't have any other packages that need evolution-python you can yum
remove evolution-python to get rid of the conflict.

As for the development packages - that is actually a problem with
gnome-python2-evolution and not hamster-applet. I have opened a bug against
gnome-python2-evolution (#450932)

*** This bug has been marked as a duplicate of 444263 ***

Comment 2 George Notaras 2008-06-11 21:54:49 UTC
I have removed evolution-python as suggested. Yum managed to resolve
dependencies without errors and the hamster-applet was installed correctly.

Thanks



Note You need to log in before you can comment on or make changes to this bug.