Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450893 - Add mono-addins to banshee dependencies
Summary: Add mono-addins to banshee dependencies
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: f-spot
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Nigel Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 442343
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-11 17:23 UTC by Nikolay Vladimirov
Modified: 2008-07-14 11:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-14 11:44:31 UTC


Attachments (Terms of Use)
Banshee log (deleted)
2008-06-11 17:23 UTC, Nikolay Vladimirov
no flags Details

Description Nikolay Vladimirov 2008-06-11 17:23:15 UTC
Description of problem:
Banshe crashes on startup with some assembly error.

Version-Release number of selected component (if applicable):
banshee-1.0.0-1.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. yum remove \*mono\*
2. yum install banshee
1. Start banshee
  
Actual results:
Banshe crashes on startup with some assembly error.

Expected results:
Normal operation.


Additional info:
yum install banshee
doesn't seem to install mono-addins wich is needed by banshee. 
Installation of mono-addins fixes the problem.


I'm attaching the error log for reference.

Comment 1 Nikolay Vladimirov 2008-06-11 17:23:15 UTC
Created attachment 308966 [details]
Banshee log

Comment 2 Nigel Jones 2008-06-12 23:51:55 UTC
I don't have a chance to reproduce this at the moment, but mono(Mono.Addins)
(provided by mono-addins) is marked as a requires.

I'll have a look over the next couple of days, all I can say at the moment is
that it seems odd.

Comment 3 David Andersson 2008-06-19 21:27:04 UTC
yum provides "mono(Mono.Addins)"
Loaded plugins: refresh-packagekit
mono-addins.i386 : Addins for mono
f-spot.i386 : Photo management application
f-spot.i386 : Photo management application
mono-addins.i386 : Addins for mono

Seems there are two packages providing mono(Mono.Addins) and yum happens to pick
f-spot over mono-addins.

Comment 4 Nikolay Vladimirov 2008-06-20 09:24:32 UTC
Yes, I can confirm that this is the problem I'm having. I thought that fspot is
just some strange dependency used for album art or something like that. 

Comment 5 Nigel Jones 2008-06-22 00:35:04 UTC
Thanks guys, I hadn't got that far yet :)

Bouncing off to f-spot...

Notes:
I saw this once before with banshee providing ndesk-glib, however when I built
it again in koji, the dependency changed, I think this is just weirdness in the
RPM mono dependency checker.
SO...
A rebuild might/should solve this.

Comment 6 Nigel Jones 2008-07-06 08:19:05 UTC
Looks like it's a case of easier said that done, I hadn't actually realized at the time but f-spot was 
orphaned, I'm now taking over maintainership, lets see if we can fix this once and for-all.

Comment 7 Nigel Jones 2008-07-14 11:44:19 UTC
This should be fixed with f-spot 0.4.4-4.fc10 which will hopefully appear in 
tomorrow's repo mash.

Thank you for taking the time in reporting the bug.


Note You need to log in before you can comment on or make changes to this bug.