Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 450478 - GDM & VNC & FC9
Summary: GDM & VNC & FC9
Keywords:
Status: CLOSED DUPLICATE of bug 452528
Alias: None
Product: Fedora
Classification: Fedora
Component: vnc
Version: 9
Hardware: i586
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-09 00:04 UTC by Jonathan Loh
Modified: 2013-04-30 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 18:19:02 UTC


Attachments (Terms of Use)
settings (deleted)
2008-06-09 00:04 UTC, Jonathan Loh
no flags Details

Description Jonathan Loh 2008-06-09 00:04:24 UTC
Description of problem:

Trying to run vnc and gdm it worked on FC6-7.  But I upgraded to 9, and it does
not work.  I suspect it may be due to the fact that gdm was upgraded.

What I mean by it does'nt work is that vnc connects and a window is brought up
on the remote computer but rather than having me log in.  It just gives me a
blank screen.  Previously, I was presented with a login screen.


Version-Release number of selected component (if applicable):

vnc-4.1.2-30.fc9.i386
gdm-2.22.0-5.fc9.i386

How reproducible:

Just did a fresh install on another box and it doesn't work either.
I'll include my pertinent config files


Steps to Reproduce:
1.  Need gdm, xinet, and vnc installed
2.  Add the configs
3.  vncviewer localhost:0

Oh and then you'll need to punch the requisite holes in your firewall.
I'm not using SELinux so it isn't that.

  
Actual results:

get a grey window.

Expected results:

Should be prompted for a login.


Additional info:

Comment 1 Jonathan Loh 2008-06-09 00:04:24 UTC
Created attachment 308664 [details]
settings

Comment 2 Ian Mortimer 2008-06-10 03:36:25 UTC
I'm having the same problem with a configuration that worked with F8.  When Xvnc
starts from xinetd on F8 two new processes start:

/usr/sbin/gdm-binary -nodaemon
/usr/libexec/gdmlogin

On F9, no extra gdm related processes start (hence the blank screen).


Comment 3 Ian Mortimer 2008-06-10 04:09:06 UTC
Similar result with vnc-ltsp-config.  

Comment 4 Adam Tkac 2008-06-23 14:17:20 UTC
(In reply to comment #2)
> I'm having the same problem with a configuration that worked with F8.  When Xvnc
> starts from xinetd on F8 two new processes start:
> 
> /usr/sbin/gdm-binary -nodaemon
> /usr/libexec/gdmlogin
> 
> On F9, no extra gdm related processes start (hence the blank screen).
> 

It seems that you are running machine in runlevel 3. I think that in F8 you
modified /etc/inittab to start gdm also in runlevel 3 (line
"x:5:respawn:/etc/X11/prefdm -nodaemon" changed to "x:35:respawn:/etc/X11/prefdm
-nodaemon" or something similar). Would it be possible confirm it, please? Thanks

Comment 5 Adam Tkac 2008-06-23 14:18:28 UTC
Added ian@physics.uq.edu.au to CC (please see comment #4)

Comment 6 Adam Tkac 2008-06-23 15:27:24 UTC
Next problem is in gdm because it parses custom.conf configuration file wrongly
- see bug #452528

Comment 7 Ian Mortimer 2008-06-23 23:05:09 UTC
> It seems that you are running machine in runlevel 3. 

In this case (on F8) the (server) host is in runlevel 5:

# runlevel
N 5


--
Ian




Comment 8 Adam Tkac 2008-06-24 11:13:33 UTC
(In reply to comment #7)
> > It seems that you are running machine in runlevel 3. 
> 
> In this case (on F8) the (server) host is in runlevel 5:
> 

Small misunderstood. I'm talking about that broken F9 machine. Does it also
running in runlevel 5? If yes then gdm-binary should run. In other runlevels gdm
doesn't run.

Comment 9 Ian Mortimer 2008-06-24 21:27:32 UTC
(In reply to comment #8)

> Small misunderstood. I'm talking about that broken F9 machine. Does it also
> running in runlevel 5? If yes then gdm-binary should run. In other runlevels gdm
> doesn't run.

Both hosts (working f8 and failing f9) are in runlevel 5 and gdm-binary is
running on both.  I was talking about an *additional* gdm-binary and a gdmlogin
process which gets launched on f8 when you make a vnc connection.  No
*additional* gdm related processes get launched on f9 when you make a vnc
connection.

What this indicates (I think) is that it's a gdm problem rather than a xinetd or
vncserver problem.


--
Ian



Comment 10 Adam Tkac 2008-06-26 18:19:02 UTC
(In reply to comment #9)
> What this indicates (I think) is that it's a gdm problem rather than a xinetd or
> vncserver problem.
> 

Right you are

*** This bug has been marked as a duplicate of 452528 ***


Note You need to log in before you can comment on or make changes to this bug.