Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 449786 - kernel-2.6.26-0.45.rc4.git2.fc10.i686 will not boot with kvm
Summary: kernel-2.6.26-0.45.rc4.git2.fc10.i686 will not boot with kvm
Keywords:
Status: CLOSED DUPLICATE of bug 453981
Alias: None
Product: Fedora
Classification: Fedora
Component: kvm
Version: rawhide
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Glauber Costa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-03 15:44 UTC by Clyde E. Kunkel
Modified: 2013-01-10 04:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 22:20:52 UTC


Attachments (Terms of Use)

Description Clyde E. Kunkel 2008-06-03 15:44:00 UTC
Description of problem:
This may not be kvm problem, but I have no experience to aid me.

While in rawhide, when booting kernel-2.6.26-0.45.rc4.git2.fc10.i686, msg
Booting the kernel appears and then nothing. 

Version-Release number of selected component (if applicable):
kvm-69-1.fc10.i386

How reproducible:
every time in rawhide

Steps to Reproduce:
1. boot rawhide
2. start virt-manager from a gnome terminal (won't start from menu)
3. start vm and allow vm to auto boot kernel

  
Actual results:
msg:  Booting the kernel appears and then the vm hangs

Expected results:
normal startup of rawhide in VM

Additional info:
[root@P5K-EWIFI ~]# rpm -q kvm
kvm-69-1.fc10.i386
[root@P5K-EWIFI ~]# virsh
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # version
Compiled against library: libvir 0.4.2
Using library: libvir 0.4.2
Using API: QEMU 0.4.2
Running hypervisor: QEMU 0.9.1

Also see this in dmesg | tail after several attempts.

virbr0: port 1(vnet0) entering learning state
virbr0: topology change detected, propagating
virbr0: port 1(vnet0) entering forwarding state
/usr/share/virt[3823]: segfault at 1c ip 0100080f sp bff27140 error 4 in
libgtk-vnc-1.0.so.0.0.1[fef000+1c000]
virbr0: port 1(vnet0) entering disabled state
device vnet0 left promiscuous mode
virbr0: port 1(vnet0) entering disabled state
device vnet0 entered promiscuous mode
virbr0: port 1(vnet0) entering listening state
kvm: guest NX capability removed
kvm: guest NX capability removed
vnet0: no IPv6 routers present
virbr0: port 1(vnet0) entering learning state
virbr0: topology change detected, propagating
virbr0: port 1(vnet0) entering forwarding state
/usr/share/virt[3830]: segfault at 1c ip 0100080f sp bf96f380 error 4 in
libgtk-vnc-1.0.so.0.0.1[fef000+1c000]

Comment 1 Glauber Costa 2008-06-04 05:40:44 UTC
From what you describe, it seems a bug in the vnc client, so the machine might
well be going all right. Is that what you mean by a "hang" ?

Comment 2 Clyde E. Kunkel 2008-06-04 15:50:42 UTC
By hang I mean that there are no additional msgs on the virtual console after
the booting the kernel msg.  Clicking pause kills the virt-manager gui. 
Shut-down has no effect.  After restarting the virt-manager, it shows the guest
with cpu % oscillating between 49.95 and 50.00%.

I reverted vnc, vnc-libs, gtk-vnc and gtk-vnc-python to F9 final versions, but
that didn't change anything that I could see.  Pausing the guest still kills
virt-manager and the F10 kernel still won't boot.  Now it appears that the guest
disk images are corrupt since I used destroy to stop then since shutdown wasn't
working.  Now I can't boot the f9 kernel which was working ok.  I may have to
recreate the guest now to continue trouble shooting, but am willing to do that.  

Any trouble shooting steps/advice much appreciated.



Comment 3 Will Woods 2008-06-26 18:09:09 UTC
AFAICT kernel-2.6.26-0.93.rc8.f10.i686 doesn't work either. Same result: virtual
machine starts up, kernel/initrd are loaded into memory, and then.. nothing.

This is with kvm-70-2.fc10. 

I'm told there may be some kvm fixes in the pipeline for the kernel; we'll see.

Comment 4 Jeremy Katz 2008-06-26 18:45:42 UTC
FYI, kvm-70 userspace + f9 kernel is okay... so it's something in the kernel
bits that are in 2.6.26 interacting with kvm-70

Haven't gotten further in looking at it

Comment 5 Chuck Ebbert 2008-06-26 18:47:17 UTC
(In reply to comment #3)
> AFAICT kernel-2.6.26-0.93.rc8.f10.i686 doesn't work either. Same result: virtual
> machine starts up, kernel/initrd are loaded into memory, and then.. nothing.
> 
> This is with kvm-70-2.fc10. 
> 
> I'm told there may be some kvm fixes in the pipeline for the kernel; we'll see.

Those fixes are already in 2.6.26-rc8


Comment 6 Mark McLoughlin 2008-07-07 22:20:52 UTC
Pretty sure this is bug #453981

To confirm, set up a serial console and set earlyprintk=serial and you should
see see the guest hang at e.g. :

     0MB HIGHMEM available.
     511MB LOWMEM available.

*** This bug has been marked as a duplicate of 453981 ***


Note You need to log in before you can comment on or make changes to this bug.